aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-03-06 13:52:36 +0000
committerRene Ladan <rene@FreeBSD.org>2014-03-06 13:52:36 +0000
commit459950e261e4732c17bfd4cc781a84c5324055dd (patch)
tree00a7e52396d231f3ad6a224b1dd738c3b173c794
parent3476962c49eaafdef72e2d39719fc0cc00953aed (diff)
downloadports-459950e261e4732c17bfd4cc781a84c5324055dd.tar.gz
ports-459950e261e4732c17bfd4cc781a84c5324055dd.zip
MFH: r347055
Fix build on 8.4 (which uses GCC now because of c++11-lib) Instead of removing the -Wno-unknown-warning-option, split this out in a Clang specific version and a GCC specific version (yay). Submitted by: George Mitchell via freebsd-ports Approved by: portmgr (erwin, miwi)
Notes
Notes: svn path=/branches/2014Q1/; revision=347199
-rw-r--r--www/chromium/Makefile17
-rw-r--r--www/chromium/files/extra-patch-gcc12
2 files changed, 22 insertions, 7 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 9b5dc5f05f2f..f2d851d77f27 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -20,7 +20,7 @@ LICENSE= BSD3CLAUSE LGPL21 MPL
LICENSE_COMB= multi
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-CFLAGS+= -fno-stack-protector -Wno-unknown-warning-option
+CFLAGS+= -fno-stack-protector
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
bash:${PORTSDIR}/shells/bash \
@@ -148,12 +148,6 @@ CONFIGURE_ENV+= CC=${CC} \
CXX=${CXX} \
GYP_GENERATORS=ninja \
GYP_DEFINES="${GYP_DEFINES}"
-# according to portlint the below is passed via bsd.port.mk,
-# but 'make -V CONFIGURE_ENV' does not show it:
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
- CPPFLAGS="${CPPFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}"
MAKE_ENV+= BUILDTYPE=${BUILDTYPE} \
GPERF=${LOCALBASE}/bin/gperf
MAKE_ARGS+= -C out/${BUILDTYPE}
@@ -162,13 +156,22 @@ MAKE_ARGS+= -C out/${BUILDTYPE}
.if ${CHOSEN_COMPILER_TYPE} == gcc
GYP_DEFINES+= gcc_version=${CXX:S/g++//}
+CFLAGS+= -Wno-unknown-warning
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gcc
.else
GYP_DEFINES+= clang=1
+CFLAGS+= -Wno-unknown-warning-option
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-clang
CONFIGURE_ENV+= AR=/usr/bin/ar
.endif
+# according to portlint the below is passed via bsd.port.mk,
+# but 'make -V CONFIGURE_ENV' does not show it:
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "To build Chromium, you should have around 1 GB of memory"
diff --git a/www/chromium/files/extra-patch-gcc b/www/chromium/files/extra-patch-gcc
index 421c0f83e9ac..2306d80513fd 100644
--- a/www/chromium/files/extra-patch-gcc
+++ b/www/chromium/files/extra-patch-gcc
@@ -50,3 +50,15 @@
#if HAVE_SCHED_GETAFFINITY
#ifndef _GNU_SOURCE
# define _GNU_SOURCE
+--- content/browser/browser_shutdown_profile_dumper.cc.orig 2014-02-20 15:28:24.000000000 -0500
++++ content/browser/browser_shutdown_profile_dumper.cc 2014-03-03 15:36:33.000000000 -0500
+@@ -2,6 +2,8 @@
+ // Use of this source code is governed by a BSD-style license that can be
+ // found in the LICENSE file.
+
++#include <stdio.h>
++
+ #include "content/browser/browser_shutdown_profile_dumper.h"
+
+ #include "base/base_switches.h"
+