aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-03-08 23:35:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-03-08 23:35:13 +0000
commita73973bf9d44d82e1e109cfd75001f9d5b97bab7 (patch)
treec60347220f78a9dd7fbc76ba695e11052227d29f
parent664894e30b9f93fcad359d4409d2f57e97baf036 (diff)
downloadports-a73973bf9d44d82e1e109cfd75001f9d5b97bab7.tar.gz
ports-a73973bf9d44d82e1e109cfd75001f9d5b97bab7.zip
MFH: r347541
Enable use of OpenSSL in the bundled copy of libcurl. The default is off, which makes calls such as FILE(DOWNLOAD ...) from HTTPS locations fail. PR: ports/187374 Approved by: portmgr (miwi)
Notes
Notes: svn path=/branches/2014Q1/; revision=347543
-rw-r--r--devel/cmake/Makefile1
-rw-r--r--devel/cmake/files/InitialCache.cmake4
2 files changed, 5 insertions, 0 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index ae181d6bfec1..ec11c4be0a46 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cmake
PORTVERSION= 2.8.12.1
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= http://downloads.cmake.org/files/v2.8/
diff --git a/devel/cmake/files/InitialCache.cmake b/devel/cmake/files/InitialCache.cmake
index de214871c9e4..b64391a9d82e 100644
--- a/devel/cmake/files/InitialCache.cmake
+++ b/devel/cmake/files/InitialCache.cmake
@@ -4,3 +4,7 @@
# devel/qt4-corelib is not).
# See https://mail.kde.org/pipermail/kde-freebsd/2013-July/015703.html
set(BUILD_TESTING OFF CACHE BOOL "Build the testing tree.")
+
+# Explicitly enable use of OpenSSL in the bundled copy of libcurl, as it
+# defaults to off. See ports/187374.
+set(CMAKE_USE_OPENSSL ON CACHE BOOL "Use OpenSSL code with curl.")