aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-02 15:30:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-02 15:30:50 +0000
commitd08bb29d6cb24c014495227ec11f8c310bab6184 (patch)
tree13fab300b7244ef08c5cf7cf0c56c6b6d9bf708f
parent213c0d88f44e8e5e0304a71b51237a1eb8285e1e (diff)
downloadports-d08bb29d6cb24c014495227ec11f8c310bab6184.tar.gz
ports-d08bb29d6cb24c014495227ec11f8c310bab6184.zip
MFH: r338063
- Allow build with clang [1] - Remove explicit -lstdc++ - Bump PORTREVISION for package change Submitted by: vanilla [1] Approved by: portmgr (bapt, via IRC)
Notes
Notes: svn path=/branches/2014Q1/; revision=346774
-rw-r--r--databases/kyotocabinet/Makefile3
-rw-r--r--databases/kyotocabinet/files/patch-kccommon.h11
2 files changed, 13 insertions, 1 deletions
diff --git a/databases/kyotocabinet/Makefile b/databases/kyotocabinet/Makefile
index cf10c56c06ef..27dfc8af4e19 100644
--- a/databases/kyotocabinet/Makefile
+++ b/databases/kyotocabinet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kyotocabinet
PORTVERSION= 1.2.76
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/${PORTNAME}/pkg/ \
LOCAL/sunpoet
@@ -18,7 +19,6 @@ CPPFLAGS+= -fPIC
GNU_CONFIGURE= yes
MAKE_ARGS= PCDIR=${PREFIX}/libdata/pkgconfig
REINPLACE_ARGS= -i ''
-USE_GCC= any
USE_LDCONFIG= yes
USES= gmake
@@ -28,6 +28,7 @@ NOT_FOR_ARCHS_REASON= does not link
.include <bsd.port.pre.mk>
post-patch:
+ @${REINPLACE_CMD} -e 's|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile ${WRKSRC}/lab/kcdict/Makefile
.if !${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile.in
.endif
diff --git a/databases/kyotocabinet/files/patch-kccommon.h b/databases/kyotocabinet/files/patch-kccommon.h
new file mode 100644
index 000000000000..57cf0a1a9d9c
--- /dev/null
+++ b/databases/kyotocabinet/files/patch-kccommon.h
@@ -0,0 +1,11 @@
+--- kccommon.h.orig 2012-05-25 00:27:59.000000000 +0800
++++ kccommon.h 2013-12-28 01:25:49.838357594 +0800
+@@ -82,7 +82,7 @@
+ using ::snprintf;
+ }
+
+-#if __cplusplus > 199711L || defined(__GXX_EXPERIMENTAL_CXX0X__) || defined(_MSC_VER)
++#if __cplusplus > 199711L || defined(__GXX_EXPERIMENTAL_CXX0X__) || defined(_MSC_VER) || defined(_LIBCPP_VERSION)
+
+ #include <unordered_map>
+ #include <unordered_set>