aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-06-25 14:00:36 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-06-25 14:00:36 +0000
commit8cb7c1d52057ff7388212675002825b6ac257796 (patch)
tree2de7abd3468c15ea25c319fcd60419a6952f23f2
parent2bbc2f47719e9c1dede36fd148453586a0cd08ba (diff)
downloadports-8cb7c1d52057ff7388212675002825b6ac257796.tar.gz
ports-8cb7c1d52057ff7388212675002825b6ac257796.zip
Fix mismerge by synching with the version in head.
Approved by: portmgr (erwin)
Notes
Notes: svn path=/branches/2014Q2/; revision=359243
-rw-r--r--databases/phpmyadmin/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index fa7b9a0ae9a2..1cda3568e115 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -4,11 +4,11 @@
PORTNAME= phpMyAdmin
DISTVERSION= 4.2.4
CATEGORIES= databases www
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}/${DISTVERSION}
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}/${DISTVERSION}
DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
MAINTAINER= matthew@FreeBSD.org
-COMMENT= A set of PHP-scripts to manage MySQL over the web
+COMMENT= Set of PHP-scripts to manage MySQL over the web
NO_ARCH= yes
LICENSE= GPLv2
@@ -17,7 +17,7 @@ USES= shebangfix tar:xz
NO_BUILD= yes
.if !defined(WITHOUT_PHP_DEPENDS)
IGNORE_WITH_PHP=52
-USE_PHP= ctype session filter mbstring json spl
+USE_PHP= ctype session filter mbstring json spl mysqli
.endif
# Note: default settings will pull in X11 client support. If you don't
@@ -27,15 +27,10 @@ USE_PHP= ctype session filter mbstring json spl
OPTIONS_DEFINE= APC BZ2 GD MCRYPT OPENSSL PDF XML ZIP ZLIB
OPTIONS_DEFAULT= BZ2 GD MCRYPT OPENSSL XML ZIP ZLIB
-OPTIONS_MULTI= DB_connect
-OPTIONS_MULTI_DB_connect= MYSQL MYSQLI
-
APC_DESC= PHP APC (animated progress bar) support
BZ2_DESC= PHP bzip2 library support
GD_DESC= PHP GD library support (requires X11)
MCRYPT_DESC= PHP MCrypt library support
-MYSQLI_DESC= PHP Improved MySQL client support
-MYSQL_DESC= PHP MySQL support via mysql client
OPENSSL_DESC= PHP OpenSSL support
PDF_DESC= PHP PDFlib support
XML_DESC= PHP XML support (Export to OpenDoc)
@@ -52,7 +47,7 @@ CFG_FILE= config.inc.php
PLIST= ${WRKDIR}/plist
PLIST_SUB+= PMA_GRP=${GROUPS}
-SUB_LIST+= PKGNAME=${PKGNAME} \
+SUB_LIST+= PKGNAME=${PKGNAME} \
CFG_FILE=${WWWDIR}/${CFG_FILE}
SUB_FILES+= pkg-message
@@ -63,7 +58,7 @@ SHEBANG_FILES= libraries/plugins/transformations/generator_main_class.sh \
.for opt in ${OPTIONS_DEFINE} ${OPTIONS_MULTI_DB_connect}
. if ${PORT_OPTIONS:M${opt}}
-USE_PHP+= ${opt:L}
+USE_PHP+= ${opt:tl}
. endif
.endfor