aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-21 16:48:02 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-21 16:48:02 +0000
commit9039169cd8826d830440a85d9eee87e53a352601 (patch)
treecf9587ab0c2e157af0887e36695160596b871331
parent17b35bf4eb673045ba72b7905bcd190ef5ec1f80 (diff)
downloadports-9039169cd8826d830440a85d9eee87e53a352601.tar.gz
ports-9039169cd8826d830440a85d9eee87e53a352601.zip
MFH: r358308
PYTHON_PY3K_PLIST_HACK: Take @dirrmtry entries into account as well. When using the plist hack to add __pycache__ entries for Python >= 3.2.0, take @dirrmtry entries into account as well, otherwise if those directories happen to contain __pycache__ subdirectories the latter will not be removed. CR: D191 PR: 190847 Approved by: portmgr (erwin)
Notes
Notes: svn path=/branches/2014Q2/; revision=358717
-rw-r--r--Mk/bsd.python.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 4b6287a0446c..7d2c19bb9cf5 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -564,6 +564,7 @@ add-plist-post:
@${AWK} '\
/\.py[co]$$/ && !($$0 ~ "/" pc "/") {id = match($$0, /\/[^\/]+\.py[co]$$/); if (id != 0) {d = substr($$0, 1, RSTART - 1); dirs[d] = 1}; sub(/\.py[co]$$/, "." mt "&"); sub(/[^\/]+\.py[co]$$/, pc "/&"); print; next} \
/^@dirrm / {d = substr($$0, 8); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
+ /^@dirrmtry / {d = substr($$0, 11); if (d in dirs) {print $$0 "/" pc}; print $$0; next} \
{print} \
END {if (sp in dirs) {print "@dirrm " sp "/" pc}} \
' \