aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-06-07 14:57:47 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-06-07 14:57:47 +0000
commitc1230455d976f3030f51ec62fd6435613912aeaf (patch)
treed407914aaeb2202088953dfe8671f766ea11be61
parent33799e86ed6e92b21b69540e45dc2514b077ef68 (diff)
downloadports-c1230455d976f3030f51ec62fd6435613912aeaf.tar.gz
ports-c1230455d976f3030f51ec62fd6435613912aeaf.zip
MFH: r356899
- New upstream release 1.0.1 - Un-break build with clang - Stagify - Introduce NLS OPTION - USE_* -> USES - Shared lib convention: shlib.X -> libshlib.so - Pet portlint Approved by: portmgr (swills), mentors (implicit)
Notes
Notes: svn path=/branches/2014Q2/; revision=356909
-rw-r--r--multimedia/ogmrip/Makefile44
-rw-r--r--multimedia/ogmrip/distinfo4
-rw-r--r--multimedia/ogmrip/files/patch-data-Makefile.in13
-rw-r--r--multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c138
-rw-r--r--multimedia/ogmrip/pkg-plist23
5 files changed, 192 insertions, 30 deletions
diff --git a/multimedia/ogmrip/Makefile b/multimedia/ogmrip/Makefile
index f7141e0c0b54..8f4fc72d04f4 100644
--- a/multimedia/ogmrip/Makefile
+++ b/multimedia/ogmrip/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ogmrip
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}
@@ -16,42 +15,40 @@ LICENSE_COMB= multi
BUILD_DEPENDS= mencoder:${PORTSDIR}/multimedia/mencoder \
mplayer:${PORTSDIR}/multimedia/mplayer \
gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS= enca.5:${PORTSDIR}/converters/enca \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- dvdread.4:${PORTSDIR}/multimedia/libdvdread
+LIB_DEPENDS= libenca.so:${PORTSDIR}/converters/enca \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libdvdread.so:${PORTSDIR}/multimedia/libdvdread
RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
oggenc:${PORTSDIR}/audio/vorbis-tools \
mencoder:${PORTSDIR}/multimedia/mencoder \
mplayer:${PORTSDIR}/multimedia/mplayer \
ogmmerge:${PORTSDIR}/multimedia/ogmtools
-OPTIONS_DEFINE= GTK2 ENCHANT MATROSKA MP4BOX THEORA FAAC SRT DEBUG
-OPTIONS_DEFAULT=GTK2
+OPTIONS_DEFINE= GTK2 ENCHANT MATROSKA MP4BOX NLS THEORA FAAC SRT DEBUG
+OPTIONS_DEFAULT=GTK2 NLS
ENCHANT_DESC= Enable spell checking for text subtitles
MATROSKA_DESC= Enable Matroska container support
MP4BOX_DESC= Enable Mpeg-4 container support
THEORA_DESC= Enable Ogg Theora video codec support
SRT_DESC= Enable SRT text subtitles support
-USES= pathfix gettext gmake pkgconfig
+USES= desktop-file-utils gmake libtool:keepla pathfix pkgconfig
USE_GNOME= glib20 intlhack libxml2
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= dvdcpy.1 avibox.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --enable-gtk-support --enable-dbus-support \
--enable-libnotify-support
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libnotify.so:${PORTSDIR}/devel/libnotify
USE_GNOME+= gconf2 libglade2
GCONF_SCHEMAS= ogmrip.schemas
PLIST_SUB+= GTK2_SUPPORT=""
@@ -63,7 +60,7 @@ PLIST_SUB+= GTK2_SUPPORT="@comment "
.if ${PORT_OPTIONS:MENCHANT}
CONFIGURE_ARGS+= --enable-enchant-support
-LIB_DEPENDS+= enchant:${PORTSDIR}/textproc/enchant
+LIB_DEPENDS+= libenchant.so:${PORTSDIR}/textproc/enchant
PLIST_SUB+= ENCHANT_SUPPORT=""
.else
CONFIGURE_ARGS+= --disable-enchant-support
@@ -88,9 +85,17 @@ CONFIGURE_ARGS+= --disable-mp4-support
PLIST_SUB+= MP4BOX_SUPPORT="@comment "
.endif
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if ${PORT_OPTIONS:MTHEORA}
CONFIGURE_ARGS+= --enable-theora-support
-LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
+LIB_DEPENDS+= libtheora.so:${PORTSDIR}/multimedia/libtheora
PLIST_SUB+= THEORA_SUPPORT=""
.else
CONFIGURE_ARGS+= --disable-theora-support
@@ -135,9 +140,4 @@ post-patch:
@${REINPLACE_CMD} -e \
'/PROGRAM/s|MP4Box|mp4box|g' ${WRKSRC}/libogmrip/ogmrip-mp4.c
-post-install:
- @${ECHO_MSG} ""
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG} ""
-
.include <bsd.port.mk>
diff --git a/multimedia/ogmrip/distinfo b/multimedia/ogmrip/distinfo
index 744bff8ec12a..7b5b0d4f2780 100644
--- a/multimedia/ogmrip/distinfo
+++ b/multimedia/ogmrip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ogmrip-1.0.0.tar.gz) = 6848a622152a62899b6e876e70ec36df1af7be9803b8b9c809ed631196bc18cc
-SIZE (ogmrip-1.0.0.tar.gz) = 3262205
+SHA256 (ogmrip-1.0.1.tar.gz) = 1c7bb9a346f94a0b6ba783d71df7d21ce021b2f179f5c1a2ebf870366d53ed56
+SIZE (ogmrip-1.0.1.tar.gz) = 3276396
diff --git a/multimedia/ogmrip/files/patch-data-Makefile.in b/multimedia/ogmrip/files/patch-data-Makefile.in
new file mode 100644
index 000000000000..0122edcf444f
--- /dev/null
+++ b/multimedia/ogmrip/files/patch-data-Makefile.in
@@ -0,0 +1,13 @@
+--- data/Makefile.in.orig 2014-05-30 20:04:27.000000000 +0200
++++ data/Makefile.in 2014-06-07 09:59:01.045874372 +0200
+@@ -719,10 +719,6 @@
+ @HAVE_GTK_SUPPORT_TRUE@@INTLTOOL_DESKTOP_RULE@
+ @HAVE_GTK_SUPPORT_TRUE@@INTLTOOL_SCHEMAS_RULE@
+
+-@GCONF_SCHEMAS_INSTALL_TRUE@@HAVE_GTK_SUPPORT_TRUE@install-data-local:
+-@GCONF_SCHEMAS_INSTALL_TRUE@@HAVE_GTK_SUPPORT_TRUE@ -GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
+-@GCONF_SCHEMAS_INSTALL_TRUE@@HAVE_GTK_SUPPORT_TRUE@ $(GCONFTOOL) --makefile-install-rule $(srcdir)/$(schemas_DATA)
+-
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c b/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c
new file mode 100644
index 000000000000..7cd7b71c2990
--- /dev/null
+++ b/multimedia/ogmrip/files/patch-libogmrip-ogmrip-encoding.c
@@ -0,0 +1,138 @@
+--- libogmrip/ogmrip-encoding.c.orig 2013-10-05 15:05:24.000000000 +0200
++++ libogmrip/ogmrip-encoding.c 2014-06-07 08:00:31.601300584 +0200
+@@ -1197,7 +1197,7 @@
+ encoding->priv->task.options,
+ OGMRIP_TASK_SUSPEND,
+ encoding->priv->task.type,
+- (OGMRipTaskDetail) 0);
++ (OGMRipTaskDetail) 0.0);
+ }
+
+ static void
+@@ -1208,7 +1208,7 @@
+ encoding->priv->task.options,
+ OGMRIP_TASK_RESUME,
+ encoding->priv->task.type,
+- (OGMRipTaskDetail) 0);
++ (OGMRipTaskDetail) 0.0);
+ }
+
+ static void
+@@ -1706,10 +1706,10 @@
+ return OGMJOB_RESULT_ERROR;
+
+ ogmrip_encoding_emit_task (encoding, spawn,
+- NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_ANALYZE, (OGMRipTaskDetail) 0);
++ NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_ANALYZE, (OGMRipTaskDetail) 0.0);
+ result = ogmrip_video_codec_analyze (OGMRIP_VIDEO_CODEC (spawn), 0) ? OGMJOB_RESULT_SUCCESS : OGMJOB_RESULT_CANCEL;
+ ogmrip_encoding_emit_task (encoding, spawn,
+- NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_ANALYZE, (OGMRipTaskDetail) result);
++ NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_ANALYZE, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result == OGMJOB_RESULT_SUCCESS)
+ {
+@@ -1777,9 +1777,9 @@
+ if (!spawn)
+ return OGMJOB_RESULT_ERROR;
+
+- ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_CHAPTERS, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_CHAPTERS, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (spawn, error);
+- ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_CHAPTERS, (OGMRipTaskDetail) result);
++ ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_CHAPTERS, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result != OGMJOB_RESULT_SUCCESS)
+ {
+@@ -1871,10 +1871,10 @@
+ ogmrip_codec_set_options (OGMRIP_CODEC (spawn), encoding->priv->profile_section);
+
+ ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
+- OGMRIP_TASK_RUN, OGMRIP_TASK_SUBP, (OGMRipTaskDetail) 0);
++ OGMRIP_TASK_RUN, OGMRIP_TASK_SUBP, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (spawn, error);
+ ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
+- OGMRIP_TASK_COMPLETE, OGMRIP_TASK_SUBP, (OGMRipTaskDetail) result);
++ OGMRIP_TASK_COMPLETE, OGMRIP_TASK_SUBP, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result != OGMJOB_RESULT_SUCCESS)
+ {
+@@ -1987,10 +1987,10 @@
+ ogmrip_codec_set_options (OGMRIP_CODEC (spawn), encoding->priv->profile_section);
+
+ ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
+- OGMRIP_TASK_RUN, OGMRIP_TASK_AUDIO, (OGMRipTaskDetail) 0);
++ OGMRIP_TASK_RUN, OGMRIP_TASK_AUDIO, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (spawn, error);
+ ogmrip_encoding_emit_task (encoding, spawn, (OGMRipOptions *) &data->options,
+- OGMRIP_TASK_COMPLETE, OGMRIP_TASK_AUDIO, (OGMRipTaskDetail) result);
++ OGMRIP_TASK_COMPLETE, OGMRIP_TASK_AUDIO, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result != OGMJOB_RESULT_SUCCESS)
+ {
+@@ -2058,10 +2058,10 @@
+ {
+ case OGMRIP_OPTIONS_AUTOMATIC:
+ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec),
+- NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_CROP, (OGMRipTaskDetail) 0);
++ NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_CROP, (OGMRipTaskDetail) 0.0);
+ result = ogmrip_video_codec_autocrop (codec, 0) ? OGMJOB_RESULT_SUCCESS : OGMJOB_RESULT_CANCEL;
+ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec),
+- NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_CROP, (OGMRipTaskDetail) result);
++ NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_CROP, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result != OGMJOB_RESULT_SUCCESS)
+ return OGMJOB_RESULT_CANCEL;
+@@ -2226,9 +2226,9 @@
+ if (encoding->priv->profile_section && encoding->priv->preset == OGMRIP_VIDEO_PRESET_USER)
+ ogmrip_codec_set_options (OGMRIP_CODEC (codec), encoding->priv->profile_section);
+
+- ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec), NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_VIDEO, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec), NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_VIDEO, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (OGMJOB_SPAWN (codec), error);
+- ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec), NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_VIDEO, (OGMRipTaskDetail) result);
++ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (codec), NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_VIDEO, (OGMRipTaskDetail) (gdouble) result);
+
+ if (result == OGMJOB_RESULT_ERROR && error && !(*error))
+ g_set_error (error, OGMRIP_ENCODING_ERROR, OGMRIP_ENCODING_ERROR_UNKNOWN,
+@@ -2258,9 +2258,9 @@
+ ogmjob_log_printf ("\nMerging\n");
+ ogmjob_log_printf ("-------\n\n");
+
+- ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (container), NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_MERGE, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (container), NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_MERGE, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (OGMJOB_SPAWN (container), error);
+- ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (container), NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_MERGE, (OGMRipTaskDetail) result);
++ ogmrip_encoding_emit_task (encoding, OGMJOB_SPAWN (container), NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_MERGE, (OGMRipTaskDetail) (gdouble) result);
+
+ if (cwd)
+ {
+@@ -2376,7 +2376,7 @@
+ relative = ogmrip_encoding_get_relative (encoding);
+ ogmrip_encoding_set_relative_internal (encoding, TRUE);
+
+- ogmrip_encoding_emit_task (encoding, NULL, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_TEST, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, NULL, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_TEST, (OGMRipTaskDetail) 0.0);
+
+ ogmrip_encoding_set_play_length (encoding, SAMPLE_LENGTH * SAMPLE_PERCENT);
+
+@@ -2430,7 +2430,7 @@
+ }
+ }
+
+- ogmrip_encoding_emit_task (encoding, NULL, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_TEST, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, NULL, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_TEST, (OGMRipTaskDetail) 0.0);
+
+ if (result == OGMJOB_RESULT_SUCCESS && files > 0)
+ {
+@@ -5972,9 +5972,9 @@
+
+ OGMRIP_ENCODING_SET_FLAGS (encoding, OGMRIP_ENCODING_BACKUPING);
+
+- ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_BACKUP, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_RUN, OGMRIP_TASK_BACKUP, (OGMRipTaskDetail) 0.0);
+ result = ogmjob_spawn_run (spawn, error);
+- ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_BACKUP, (OGMRipTaskDetail) 0);
++ ogmrip_encoding_emit_task (encoding, spawn, NULL, OGMRIP_TASK_COMPLETE, OGMRIP_TASK_BACKUP, (OGMRipTaskDetail) 0.0);
+
+ OGMRIP_ENCODING_UNSET_FLAGS (encoding, OGMRIP_ENCODING_BACKUPING);
+
diff --git a/multimedia/ogmrip/pkg-plist b/multimedia/ogmrip/pkg-plist
index bb2073263412..1efbab96a639 100644
--- a/multimedia/ogmrip/pkg-plist
+++ b/multimedia/ogmrip/pkg-plist
@@ -74,30 +74,37 @@ include/ogmrip/ogmrip.h
%%GTK2_SUPPORT%%lib/libogmdvd-gtk.la
%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so
%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so.1
+%%GTK2_SUPPORT%%lib/libogmdvd-gtk.so.1.0.0
lib/libogmdvd.a
lib/libogmdvd.la
lib/libogmdvd.so
lib/libogmdvd.so.1
+lib/libogmdvd.so.1.0.0
lib/libogmjob.a
lib/libogmjob.la
lib/libogmjob.so
lib/libogmjob.so.1
+lib/libogmjob.so.1.0.0
%%GTK2_SUPPORT%%lib/libogmrip-gtk.a
%%GTK2_SUPPORT%%lib/libogmrip-gtk.la
%%GTK2_SUPPORT%%lib/libogmrip-gtk.so
%%GTK2_SUPPORT%%lib/libogmrip-gtk.so.1
+%%GTK2_SUPPORT%%lib/libogmrip-gtk.so.1.0.0
lib/libogmrip-lavc.a
lib/libogmrip-lavc.la
lib/libogmrip-lavc.so
lib/libogmrip-lavc.so.1
+lib/libogmrip-lavc.so.1.0.0
lib/libogmrip-mplayer.a
lib/libogmrip-mplayer.la
lib/libogmrip-mplayer.so
lib/libogmrip-mplayer.so.1
+lib/libogmrip-mplayer.so.1.0.0
lib/libogmrip.a
lib/libogmrip.la
lib/libogmrip.so
lib/libogmrip.so.1
+lib/libogmrip.so.1.0.0
%%FAAC_SUPPORT%%lib/ogmrip/audio-plugins/libogmrip-aac.a
%%FAAC_SUPPORT%%lib/ogmrip/audio-plugins/libogmrip-aac.la
%%FAAC_SUPPORT%%lib/ogmrip/audio-plugins/libogmrip-aac.so
@@ -163,13 +170,17 @@ libdata/pkgconfig/ogmdvd.pc
libdata/pkgconfig/ogmjob.pc
libdata/pkgconfig/ogmrip-gtk.pc
libdata/pkgconfig/ogmrip.pc
+man/man1/dvdcpy.1.gz
+man/man1/avibox.1.gz
+%%SRT_SUPPORT%%man/man1/subp2pgm.1.gz
+%%SRT_SUPPORT%%man/man1/subptools.1.gz
%%GTK2_SUPPORT%%share/applications/ogmrip.desktop
-share/locale/cs/LC_MESSAGES/ogmrip.mo
-share/locale/de/LC_MESSAGES/ogmrip.mo
-share/locale/fr/LC_MESSAGES/ogmrip.mo
-share/locale/nb/LC_MESSAGES/ogmrip.mo
-share/locale/ru/LC_MESSAGES/ogmrip.mo
-share/locale/sk/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/de/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/ogmrip.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/ogmrip.mo
%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-crop.glade
%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-lavc.glade
%%GTK2_SUPPORT%%%%DATADIR%%/ogmrip-main.glade