aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2015-10-02 08:15:47 +0000
committerNicola Vitale <nivit@FreeBSD.org>2015-10-02 08:15:47 +0000
commit07991353f9b9068ef5f54ebc317983e7e740d4ec (patch)
tree4e5d28568d8fcf28b17715f547c73e67ce3f4950
parent38ec3611e255787199af4c489720c7ea7e7c3fb8 (diff)
downloadports-07991353f9b9068ef5f54ebc317983e7e740d4ec.tar.gz
ports-07991353f9b9068ef5f54ebc317983e7e740d4ec.zip
MFH: r398372
- Fix runtime error: Global symbol "@args" requires explicit package name at /usr/local/share/shutter/resources/modules/Shutter/App/HelperFunctions.pm line 56. Global symbol "@args" requires explicit package name at /usr/local/share/shutter/resources/modules/Shutter/App/HelperFunctions.pm line 57. Compilation failed in require at /usr/local/bin/shutter line 148. See also: See also: https://bugs.launchpad.net/shutter/+bug/1495163/comments/2 - Bump PORTREVISION Reviewed by: feld Approved by: portmgr (erwin)
Notes
Notes: svn path=/branches/2015Q3/; revision=398424
-rw-r--r--deskutils/shutter/Makefile2
-rw-r--r--deskutils/shutter/files/patch-CVE-2015-08542
2 files changed, 2 insertions, 2 deletions
diff --git a/deskutils/shutter/Makefile b/deskutils/shutter/Makefile
index 82bf7c5f1932..f9d5628e646f 100644
--- a/deskutils/shutter/Makefile
+++ b/deskutils/shutter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shutter
PORTVERSION= 0.93.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
MASTER_SITES= http://shutter-project.org/wp-content/uploads/releases/tars/
diff --git a/deskutils/shutter/files/patch-CVE-2015-0854 b/deskutils/shutter/files/patch-CVE-2015-0854
index 58e82b0a88ff..fed4e103a473 100644
--- a/deskutils/shutter/files/patch-CVE-2015-0854
+++ b/deskutils/shutter/files/patch-CVE-2015-0854
@@ -5,7 +5,7 @@
sub xdg_open {
my ( $self, $dialog, $link, $user_data ) = @_;
- system("xdg-open $link");
-+ @args = ("xdg-open", "$link");
++ my @args = ("xdg-open", "$link");
+ system(@args);
if($?){
my $response = $self->{_dialogs}->dlg_error_message(