aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-09-22 12:34:16 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-09-22 12:34:16 +0000
commit172c7eaf3f926a775ad41bf55f6fba87682516cb (patch)
treee6c3ba4bac845284e62ed7e1dbfa17a07dd33088
parent6bba20cb7a4a88b3728c153be6b3feb0535b153b (diff)
downloadports-172c7eaf3f926a775ad41bf55f6fba87682516cb.tar.gz
ports-172c7eaf3f926a775ad41bf55f6fba87682516cb.zip
MFH r396055, r397205:
r396055 Fix managing non-FreeBSD hosts. PR: 202799 Submitted by: merlin@merlinsbox.net Approved by: maintainer r397205 sysutils/ansible: update 1.9.2 -> 1.9.3 and add NO_ARCH Changes: https://raw.githubusercontent.com/ansible/ansible/v1.9.3-1/CHANGELOG.md PR: 202895 Submitted by: Nikolai Lifanov <lifanov@mail.lifanov.com> (maintainer) Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2015Q3/; revision=397537
-rw-r--r--sysutils/ansible/Makefile4
-rw-r--r--sysutils/ansible/distinfo4
-rw-r--r--sysutils/ansible/files/pkg-message.in6
3 files changed, 11 insertions, 3 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 58ac124dfd76..d57e99597074 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.9.2
+PORTVERSION= 1.9.3
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -19,8 +19,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
OPTIONS_DEFINE= EXAMPLES
+NO_ARCH= yes
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
+python_CMD= ${LOCALBASE}/bin/python
SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py \
lib/ansible/modules/core/*/*.py \
lib/ansible/modules/core/*/*/*.py \
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index de94451b0bdb..474c4d4fb210 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ansible-1.9.2.tar.gz) = c25ef4738b08fdfb3094247c012f3fd1b29972acbd37f988070b2a85f5fbee00
-SIZE (ansible-1.9.2.tar.gz) = 927525
+SHA256 (ansible-1.9.3.tar.gz) = 2594f642fd800056a427c1026410dc6ed8dfa7c0033f5c3d187abdb2b0d4eeed
+SIZE (ansible-1.9.3.tar.gz) = 936633
diff --git a/sysutils/ansible/files/pkg-message.in b/sysutils/ansible/files/pkg-message.in
index c83e04daf059..77c877dee42d 100644
--- a/sysutils/ansible/files/pkg-message.in
+++ b/sysutils/ansible/files/pkg-message.in
@@ -7,6 +7,9 @@ host database and a sample configuration file:
%%EXAMPLESDIR%%/hosts
%%EXAMPLESDIR%%/ansible.cfg
+To use Ansible to control FreeBSD hosts, you need to
+install the lang/python package on remote machines.
+
To use Ansible to control systems other than FreeBSD,
set the Python interpreter in the host database for
that system. Example:
@@ -22,4 +25,7 @@ that system. Example:
[centos:vars]
ansible_python_interpreter=/usr/bin/python
+If you have Python 3.x as the default, please set
+ansible_python_interpreter=%%LOCALBASE%%/bin/python2
+
===============================================================================