aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-09-28 22:03:58 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-09-28 22:03:58 +0000
commit974a162dd79ab7bf06c28b6bb64f126b422402e4 (patch)
treee837508a95fdb9a0d2f80ec1f2ff12dd9a3d18eb
parent2bcc9bfef9705d93c9a87481644cdb26282809c4 (diff)
downloadports-974a162dd79ab7bf06c28b6bb64f126b422402e4.tar.gz
ports-974a162dd79ab7bf06c28b6bb64f126b422402e4.zip
MFH: r398069
www/codeigniter: security update 2.1.4 -> 2.2.4 [1] - Add NO_ARCH - Add mcrypt to USE_PHP (2.2.0+ requirement) and sort USE_PHP - Remove hard coded PHP_DEFAULT= 5.4 [2] - Sort OPTIONS_DEFINE, fix malformed ODBC_DESC, fix sqlite3 dependency - Update pkg-descr text to match http://www.codeigniter.com/ - Update WWW to http://www.codeigniter.com/ PR: 203401 [1] PR: 200945 [2] Reported by: allanjude [2] Approved by: maintainer timeout (15 months since 2.2.0 security update) [1] Approved by: maintainer timeout (3 months) [2] Approved by: ports-secteam (feld) Security: 5114cd11-6571-11e5-9909-002590263bf5 Security: 01bce4c6-6571-11e5-9909-002590263bf5 Security: c21f4e61-6570-11e5-9909-002590263bf5 Security: f838dcb4-656f-11e5-9909-002590263bf5
Notes
Notes: svn path=/branches/2015Q3/; revision=398149
-rw-r--r--www/codeigniter/Makefile13
-rw-r--r--www/codeigniter/distinfo4
-rw-r--r--www/codeigniter/pkg-descr4
-rw-r--r--www/codeigniter/pkg-plist4
4 files changed, 14 insertions, 11 deletions
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index baad0f8ac9d4..552616a4926c 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= codeigniter
-PORTVERSION= 2.1.4
-PORTREVISION= 1
+PORTVERSION= 2.2.4
CATEGORIES= www
MASTER_SITES= http://downloads.codeigniter.com/reactor/ \
http://www.codeigniter.org.tw/download_files/
@@ -16,10 +15,10 @@ USES= zip
CONFLICTS= codeigniter-1.[0-9]*
+NO_ARCH= yes
NO_BUILD= yes
-USE_PHP= session pcre
+USE_PHP= mcrypt pcre session
WANT_PHP_WEB= yes
-PHP_DEFAULT= 5.4
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
CI_SYS_DIR= system
@@ -62,13 +61,13 @@ STD_BITS= ${CI_CONF_DIR}/index.html \
${CI_SYS_DIR}/language \
${CI_SYS_DIR}/libraries
-OPTIONS_DEFINE= APACHE MSSQL MYSQL MYSQLI ODBC PGSQL SQLITE DOCS
+OPTIONS_DEFINE= APACHE DOCS MSSQL MYSQL MYSQLI ODBC PGSQL SQLITE
APACHE_DESC= Configure for Apache-2.x
MSSQL_DESC= Install MSSQL support for PHP
MYSQL_DESC= Install MySQL support for PHP
MYSQLI_DESC= Install MySQLi support for PHP
-ODBC= Install ODBC support for PHP
+ODBC_DESC= Install ODBC support for PHP
PGSQL_DESC= Install PostgreSQL support for PHP
SQLITE_DESC= Install SQLite support for PHP
@@ -106,7 +105,7 @@ USE_PHP+= pgsql
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite
+USE_PHP+= sqlite3
.endif
.if ${PORT_OPTIONS:MDOCS}
diff --git a/www/codeigniter/distinfo b/www/codeigniter/distinfo
index 1a548847ae1d..7dae4d32f34d 100644
--- a/www/codeigniter/distinfo
+++ b/www/codeigniter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CodeIgniter_2.1.4.zip) = 5ad6f8a9a2f3dc647aec554b388a62658304c5bd4295eb50b063ef8d69da1f19
-SIZE (CodeIgniter_2.1.4.zip) = 2319027
+SHA256 (CodeIgniter_2.2.4.zip) = 5363c2f120faaba7f4966f8cef93d935ae86678778f8c98471579ae045a03278
+SIZE (CodeIgniter_2.2.4.zip) = 2341717
diff --git a/www/codeigniter/pkg-descr b/www/codeigniter/pkg-descr
index d2393dba8e45..3efcf744cb0e 100644
--- a/www/codeigniter/pkg-descr
+++ b/www/codeigniter/pkg-descr
@@ -1,5 +1,5 @@
CodeIgniter is a powerful PHP framework with a very small footprint,
-built for PHP coders who need a simple and elegant toolkit to create
+built for developers who need a simple and elegant toolkit to create
full-featured web applications.
-WWW: http://ellislab.com/codeigniter
+WWW: http://http://www.codeigniter.com/
diff --git a/www/codeigniter/pkg-plist b/www/codeigniter/pkg-plist
index 18fef0c54497..423dab819f54 100644
--- a/www/codeigniter/pkg-plist
+++ b/www/codeigniter/pkg-plist
@@ -27,6 +27,7 @@
%%WWWDIR%%/application/hooks/index.html
%%WWWDIR%%/application/index.html
%%WWWDIR%%/application/language/english/index.html
+%%WWWDIR%%/application/language/index.html
%%WWWDIR%%/application/libraries/index.html
%%WWWDIR%%/application/logs/index.html
%%WWWDIR%%/application/models/index.html
@@ -153,6 +154,8 @@
%%WWWDIR%%/system/libraries/Cache/drivers/Cache_dummy.php
%%WWWDIR%%/system/libraries/Cache/drivers/Cache_file.php
%%WWWDIR%%/system/libraries/Cache/drivers/Cache_memcached.php
+%%WWWDIR%%/system/libraries/Cache/drivers/index.html
+%%WWWDIR%%/system/libraries/Cache/index.html
%%WWWDIR%%/system/libraries/Calendar.php
%%WWWDIR%%/system/libraries/Cart.php
%%WWWDIR%%/system/libraries/Driver.php
@@ -180,4 +183,5 @@
%%WWWDIR%%/system/libraries/Zip.php
%%WWWDIR%%/system/libraries/index.html
%%WWWDIR%%/system/libraries/javascript/Jquery.php
+%%WWWDIR%%/system/libraries/javascript/index.html
@dir(%%WWWOWN%%,%%WWWGRP%%,) %%WWWDIR%%/application/cache