aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-09-16 20:28:28 +0000
committerMark Felder <feld@FreeBSD.org>2015-09-16 20:28:28 +0000
commitc50e18a119833e7a18aec671a5a922948cfc439e (patch)
tree6365eb5d9334a4112d6b1432a5653638d32e21da
parent70c78fad01586c1ece59dbf27efcb1fd0e0cd267 (diff)
downloadports-c50e18a119833e7a18aec671a5a922948cfc439e.tar.gz
ports-c50e18a119833e7a18aec671a5a922948cfc439e.zip
MFH: r393831
Adds -fPIC to CFLAGS_aarch64 to a number of ports that already have it in the amd64 CFLAGS and are failing to build. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D3321 Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2015Q3/; revision=397080
-rw-r--r--archivers/p7zip/Makefile1
-rw-r--r--audio/liba52/Makefile1
-rw-r--r--devel/libmsocket/Makefile1
-rw-r--r--graphics/freeimage/Makefile1
-rw-r--r--irc/irssi-xmpp/Makefile1
-rw-r--r--multimedia/openquicktime/Makefile1
-rw-r--r--security/lockdown/Makefile1
7 files changed, 7 insertions, 0 deletions
diff --git a/archivers/p7zip/Makefile b/archivers/p7zip/Makefile
index faffa73a1507..debec353e4cb 100644
--- a/archivers/p7zip/Makefile
+++ b/archivers/p7zip/Makefile
@@ -20,6 +20,7 @@ MAKEFILE= makefile
MAKE_ARGS= OPTFLAGS="${CXXFLAGS}"
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_ia64= -fPIC
diff --git a/audio/liba52/Makefile b/audio/liba52/Makefile
index 213c394940e7..973b6aed3975 100644
--- a/audio/liba52/Makefile
+++ b/audio/liba52/Makefile
@@ -30,6 +30,7 @@ DJBFFT_CONFIGURE_ON= --enable-djbfft
.include <bsd.port.options.mk>
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_powerpc= -fPIC
diff --git a/devel/libmsocket/Makefile b/devel/libmsocket/Makefile
index 86273742bcad..17bf1520586e 100644
--- a/devel/libmsocket/Makefile
+++ b/devel/libmsocket/Makefile
@@ -26,6 +26,7 @@ PLIST_FILES= lib/libmsocket.so \
include/msocket.h \
include/msocketutils.h
+CFLAGS_aarch64+=-fPIC -DPIC
CFLAGS_amd64+= -fPIC -DPIC
CFLAGS_iad64+= -fPIC -DPIC
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 7103c3e92297..9230406dab07 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -17,6 +17,7 @@ WRKSRC= ${WRKDIR}/FreeImage
MAKE_ARGS= CC="${CC}" CPP="${CPP}" CXX="${CXX}"
CFLAGS+= -fexceptions -fvisibility=hidden
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
PLIST_FILES= include/FreeImage.h \
diff --git a/irc/irssi-xmpp/Makefile b/irc/irssi-xmpp/Makefile
index 36d7e3617214..320886f0efec 100644
--- a/irc/irssi-xmpp/Makefile
+++ b/irc/irssi-xmpp/Makefile
@@ -21,6 +21,7 @@ USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
DATADIR= ${PREFIX}/share/irssi
DOCSDIR= ${PREFIX}/share/doc/irssi
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 47bc9b317f60..b6bdace6db12 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -20,6 +20,7 @@ USES= gmake jpeg tar:tgz
USE_LDCONFIG= yes
PKGDEINSTALL= ${PKGINSTALL}
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
OPTIONS_DEFINE= DEBUG
diff --git a/security/lockdown/Makefile b/security/lockdown/Makefile
index ee802e351571..56d4c758fa82 100644
--- a/security/lockdown/Makefile
+++ b/security/lockdown/Makefile
@@ -14,6 +14,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/lockdown
+CFLAGS_aarch64+=-fPIC
CFLAGS_amd64+= -fPIC
do-install: