aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-14 16:27:33 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-14 16:27:33 +0000
commit2bc57e19ccd85f7147578fe75ff3abe09408d7d8 (patch)
tree5a5dbb7e3eef5cc3e537f163b6659a3ec1bf6d11
parent431d29496032dfa5968086e98d8a3caaa8097b12 (diff)
downloadports-2bc57e19ccd85f7147578fe75ff3abe09408d7d8.tar.gz
ports-2bc57e19ccd85f7147578fe75ff3abe09408d7d8.zip
MFH: r411100
www/squid: Fix crashes under heavy load Squid 3.5.15 addresses security issues, but reports have been made that it is unstable under load. These patches repair stability while not requiring we downgrade to 3.5.14 which reintroduces security vulnerabilities. PR: 207762 Approved by: maintainer Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2016Q1/; revision=411101
-rw-r--r--www/squid/Makefile6
-rw-r--r--www/squid/distinfo8
-rw-r--r--www/squid/files/patch-configure23
3 files changed, 26 insertions, 11 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index b0df443bbe33..ae4baae50661 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -2,6 +2,7 @@
PORTNAME= squid
PORTVERSION= 3.5.15
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
http://www2.us.squid-cache.org/Versions/v3/${PORTVERSION:R}/ \
@@ -17,7 +18,10 @@ PATCH_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www1.jp.squid-cache.org/%SUBDIR%/ \
http://master.squid-cache.org/~amosjeffries/patches/:nosid
PATCH_SITE_SUBDIR= Versions/v3/${PORTVERSION:R}/changesets
-PATCHFILES= # empty
+PATCHFILES= squid-3.5-13997.patch \
+ squid-3.5-13998.patch \
+ squid-3.5-13999.patch \
+ squid-3.5-14000.patch
MAINTAINER= timp87@gmail.com
COMMENT= HTTP Caching Proxy
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 654375a3abc5..53f08f537edc 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -1,2 +1,10 @@
SHA256 (squid3.5/squid-3.5.15.tar.xz) = 9cfce3231c7b3b33816fc54414d8720a51ac5e723663e0685a8bb995b9f450d2
SIZE (squid3.5/squid-3.5.15.tar.xz) = 2315628
+SHA256 (squid3.5/squid-3.5-13997.patch) = 43533b41af0e5d067c576de87842b85a33bac9b293c19d816fa1475324eb89fd
+SIZE (squid3.5/squid-3.5-13997.patch) = 1509
+SHA256 (squid3.5/squid-3.5-13998.patch) = c53a9d3e48224b06eedb5867b248e1b1c1226deab73c7c4d9ce8f72524e91214
+SIZE (squid3.5/squid-3.5-13998.patch) = 8184
+SHA256 (squid3.5/squid-3.5-13999.patch) = 07e82e0b7f0d766de443277f1153165177c867cbc75514890f2fe4de8d43c820
+SIZE (squid3.5/squid-3.5-13999.patch) = 1585
+SHA256 (squid3.5/squid-3.5-14000.patch) = 36578a13e87150d1604b543c68b419de1c941be3f90e80fbf464f9c23139e2de
+SIZE (squid3.5/squid-3.5-14000.patch) = 1676
diff --git a/www/squid/files/patch-configure b/www/squid/files/patch-configure
index 7d6f2770d818..7b58a4976fc1 100644
--- a/www/squid/files/patch-configure
+++ b/www/squid/files/patch-configure
@@ -1,15 +1,18 @@
--- configure.orig 2015-11-01 10:46:19 UTC
+++ configure
-@@ -27107,9 +27107,6 @@
- if test "x$ac_cv_path_krb5_config" != "xno" ; then
- krb5confpath="`dirname $ac_cv_path_krb5_config`"
- ac_heimdal="`$ac_cv_path_krb5_config --version 2>/dev/null | grep -c -i heimdal`"
-- if test "x$with_heimdal_krb5" = "xyes"; then
-- as_fn_error $? "Could not find pkg-config or krb5-config for Heimdal Kerberos" "$LINENO" 5
-- fi
- else
- if test "x$with_heimdal_krb5" = "xyes"; then
- as_fn_error $? "Could not find krb5-config in path" "$LINENO" 5
+@@ -27729,9 +27729,11 @@
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ squid_pc_krb5_name="heimdal-gssapi"
++ else
++ squid_pc_krb5_name="heimdal-gssapi"
+ fi
+ fi
+- if test "x$squid_pc_krb5_name" != "x" -a "$cross_compiling" = "no"; then
++ if test "x$squid_pc_krb5_name" = "x" -a "$cross_compiling" = "no"; then
+ # Look for krb5-config (unless cross-compiling)
+ # Extract the first word of "krb5-config", so it can be a program name with args.
+ set dummy krb5-config; ac_word=$2
@@ -32038,7 +32040,7 @@ done
##