aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-02-29 06:17:32 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-02-29 06:17:32 +0000
commit5a9c420f6a86d2f799c73c1e53732def71cea159 (patch)
tree57e974167ac71c69e314146a9816f2abcf87d84a
parentee1f7aafea2872f64ea27fdd7fc0cd7b29ea39eb (diff)
downloadports-5a9c420f6a86d2f799c73c1e53732def71cea159.tar.gz
ports-5a9c420f6a86d2f799c73c1e53732def71cea159.zip
MFH: r409735
Respect timezone settings, remove unnecessary pkg-install script Detailed maintainer log: - Remove the setting of the TZ, LC_ALL and LANG shell variables from rc script. This resolves an issue where the emby-server timezone was set to UTC, causing show air dates and TV guides to be off by a number of hours for some users [1]. Setting these variables was originally added when mono 3.12.1 was in the ports tree, to avoid mono throwing a number of System.TimeZoneNotFound exceptions when run in debugging mode [2]. Whilst these exceptions are still thrown, they are caught and the mono code now only sets the time to UTC if the correct timezone cannot be found from the TZ variable or /etc/localtime. - Remove pkg-install script as it is no longer necessary to download Mozilla's root certificates and import them into the Mono Trust store (this was actually never effective, as the certificates were saved into the root user's mono trust store instead of the emby user's store). - Bump PORTREVISION [1] http://emby.media/community/index.php?/topic/13083-freenas-plugin/?p=299783 [2] mono --debug --trace=N:nothing /usr/local/lib/emby-server/MediaBrowser.Server.Mono.exe -ffmpeg /usr/local/bin/ffmpeg -ffprobe /usr/local/bin/ffprobe -programdata /var/db/emby-server PR: 207436 Submitted by: woodsb02@gmail.com (maintainer) Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2016Q1/; revision=409801
-rw-r--r--multimedia/emby-server/Makefile1
-rw-r--r--multimedia/emby-server/files/emby-server.in7
-rw-r--r--multimedia/emby-server/pkg-install15
3 files changed, 1 insertions, 22 deletions
diff --git a/multimedia/emby-server/Makefile b/multimedia/emby-server/Makefile
index a91f8ad207cf..7a17cfc84899 100644
--- a/multimedia/emby-server/Makefile
+++ b/multimedia/emby-server/Makefile
@@ -3,6 +3,7 @@
PORTNAME= emby-server
PORTVERSION= 3.0.5781.2
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= woodsb02@gmail.com
diff --git a/multimedia/emby-server/files/emby-server.in b/multimedia/emby-server/files/emby-server.in
index 3bb510367ce1..0a571f0b78fd 100644
--- a/multimedia/emby-server/files/emby-server.in
+++ b/multimedia/emby-server/files/emby-server.in
@@ -50,13 +50,6 @@ command_args="-f -p ${pidfile} ${procname} %%PREFIX%%/lib/emby-server/MediaBrows
start_precmd=%%RC_NAME%%_precmd
%%RC_NAME%%_precmd()
{
- : ${LC_ALL:="C"}
- : ${LANG:="C"}
- : ${TZ:="UTC"}
- export LC_ALL
- export LANG
- export TZ
-
if [ ! -e "${pidfile}" ]; then
install -g ${%%RC_NAME%%_group} -o ${%%RC_NAME%%_user} -- /dev/null "${pidfile}";
fi
diff --git a/multimedia/emby-server/pkg-install b/multimedia/emby-server/pkg-install
deleted file mode 100644
index dd55c74de183..000000000000
--- a/multimedia/emby-server/pkg-install
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
-fi
-
-case $2 in
- POST-INSTALL)
- echo "Downloading Mozilla's root certificates and importing into the Mono Trust store..."
- ${PKG_PREFIX}/bin/mozroots --import --sync
- ;;
-esac
-
-exit 0