aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-17 21:08:07 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-17 21:08:07 +0000
commit7c7ddae7027f3d55f192d47343296a98a388dcea (patch)
tree5c10eb809126e1eceef66454e9e078805e43547c
parent7c0ca444d8f474a411b2110af8e44a36821e9230 (diff)
downloadports-7c7ddae7027f3d55f192d47343296a98a388dcea.tar.gz
ports-7c7ddae7027f3d55f192d47343296a98a388dcea.zip
MFH: r411315
net/dbeacon: Unbreak port - New MAINTAINER - New MASTER_SITE - Add patch to clean up some build errors - Cleaned up pkg-descr PR: 208048 Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2016Q1/; revision=411316
-rw-r--r--net/dbeacon/Makefile6
-rw-r--r--net/dbeacon/files/patch-dbeacon.cpp34
-rw-r--r--net/dbeacon/pkg-descr10
3 files changed, 41 insertions, 9 deletions
diff --git a/net/dbeacon/Makefile b/net/dbeacon/Makefile
index 3a23a37df046..21827d105508 100644
--- a/net/dbeacon/Makefile
+++ b/net/dbeacon/Makefile
@@ -4,13 +4,11 @@
PORTNAME= dbeacon
PORTVERSION= 0.3.9.1
CATEGORIES= net
-MASTER_SITES= http://fivebits.net/files/dbeacon/
+MASTER_SITES= http://BSDforge.com/projects/source/net/dbeacon/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Distributed multicast beacon server
-BROKEN= unfetchable
-
LICENSE= GPLv2 # or later
USES= gmake
diff --git a/net/dbeacon/files/patch-dbeacon.cpp b/net/dbeacon/files/patch-dbeacon.cpp
new file mode 100644
index 000000000000..089588052e2e
--- /dev/null
+++ b/net/dbeacon/files/patch-dbeacon.cpp
@@ -0,0 +1,34 @@
+--- dbeacon.cpp.orig 2016-03-15 16:06:23.135551000 -0700
++++ dbeacon.cpp 2016-03-15 16:08:13.104873000 -0700
+@@ -1498,7 +1498,7 @@
+ fprintf(fp, " contact=\"%s\"", adminContact.c_str());
+ if (!twoLetterCC.empty())
+ fprintf(fp, " country=\"%s\"", twoLetterCC.c_str());
+- fprintf(fp, " age=\"%llu\" lastupdate=\"0\" rxlocal=\"true\">\n", (now - startTime) / 1000);
++ fprintf(fp, " age=\"%lu\" lastupdate=\"0\" rxlocal=\"true\">\n", (now - startTime) / 1000);
+
+ for (uint32_t k = 0; k < KnownFlags; k++) {
+ if (flags & (1 << k)) {
+@@ -1526,8 +1526,8 @@
+ if (!i->second.CC.empty())
+ fprintf(fp, " country=\"%s\"", i->second.CC.c_str());
+
+- fprintf(fp, " age=\"%llu\"", (now - i->second.creation) / 1000);
+- fprintf(fp, " lastupdate=\"%llu\">\n", (now - i->second.lastevent) / 1000);
++ fprintf(fp, " age=\"%lu\"", (now - i->second.creation) / 1000);
++ fprintf(fp, " lastupdate=\"%lu\">\n", (now - i->second.lastevent) / 1000);
+
+ if (i->second.ASM.s.valid)
+ dumpStats(fp, "asm", i->second.ASM.s, now, i->second.sttl, true);
+@@ -1552,9 +1552,9 @@
+ }
+ i->first.print(tmp, sizeof(tmp));
+ fprintf(fp, " addr=\"%s\"", tmp);
+- fprintf(fp, " age=\"%llu\"", (now - i->second.creation) / 1000);
++ fprintf(fp, " age=\"%lu\"", (now - i->second.creation) / 1000);
+ fprintf(fp, " rxlocal=\"%s\"", i->second.rxlocal(now) ? "true" : "false");
+- fprintf(fp, " lastupdate=\"%llu\">\n", (now - i->second.lastevent) / 1000);
++ fprintf(fp, " lastupdate=\"%lu\">\n", (now - i->second.lastevent) / 1000);
+
+ for (uint32_t k = 0; k < KnownFlags; k++) {
+ if (i->second.Flags & (1 << k)) {
diff --git a/net/dbeacon/pkg-descr b/net/dbeacon/pkg-descr
index b1ba58ab1895..6c6747e420e0 100644
--- a/net/dbeacon/pkg-descr
+++ b/net/dbeacon/pkg-descr
@@ -1,7 +1,7 @@
-Dbeacon is a distributed multicast monitoring tool. The main purpose of a
-beacon is to monitor other beacons' reachability and to collect statistics
-such as loss, delay, and jitter between beacons. Dbeacon supports both
-IPv4 and IPv6 multicast and supports collecting information using both Any
-Source Multicast (ASM) and Source-Specific Multicast (SSM).
+Dbeacon is a distributed multicast monitoring tool. The main purpose of a
+beacon is to monitor other beacons' reachability and to collect statistics
+such as loss, delay, and jitter between beacons. Dbeacon supports both
+IPv4, and IPv6 multicast, and supports collecting information using both
+Any Source Multicast (ASM) and Source-Specific Multicast (SSM).
WWW: http://fivebits.net/proj/dbeacon