aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-12-06 05:02:24 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-12-06 05:02:24 +0000
commit60cf3e1f72f0447fa1580d9f444be467ac601dd7 (patch)
tree6101b214dfd22eabfaddfb73d156b9855199748e
parent49a2a9e8c84f74ae232b8f6d1df8c5e8e4d93576 (diff)
downloadports-60cf3e1f72f0447fa1580d9f444be467ac601dd7.tar.gz
ports-60cf3e1f72f0447fa1580d9f444be467ac601dd7.zip
MFH: r427775 (w/ r424630) www/py-django-mezzanine: Update to 4.2.2, Mark Un'BROKEN
- Update PORTVERSION and distinfo checksum (4.2.2) - Update RUN_DEPENDS. In particular, switch to Django 1.8 and mark un'BROKEN accordingly - Remove setup.py patch. No longer necessary. - Enable concurrent Python installation X-MFH-With: 424630 Approved by: ports-secteam (junovich)
Notes
Notes: svn path=/branches/2016Q4/; revision=427933
-rw-r--r--www/py-django-mezzanine/Makefile18
-rw-r--r--www/py-django-mezzanine/distinfo5
-rw-r--r--www/py-django-mezzanine/files/patch-setup.py27
3 files changed, 11 insertions, 39 deletions
diff --git a/www/py-django-mezzanine/Makefile b/www/py-django-mezzanine/Makefile
index 35f5a67b1956..b202a4a9285d 100644
--- a/www/py-django-mezzanine/Makefile
+++ b/www/py-django-mezzanine/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= django-mezzanine
-PORTVERSION= 3.1.10
-PORTREVISION= 2
+PORTVERSION= 4.2.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,24 +14,23 @@ COMMENT= Content management platform built using the Django framework
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:www/py-django16 \
- ${PYTHON_PKGNAMEPREFIX}django-mezzanine-filebrowser>=0.3.4:www/py-django-mezzanine-filebrowser \
- ${PYTHON_PKGNAMEPREFIX}django-mezzanine-grappelli>=0.3.12:www/py-django-mezzanine-grappelli \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=1.8:www/py-django18 \
+ ${PYTHON_PKGNAMEPREFIX}django-contrib-comments>0:www/py-django-contrib-comments \
+ ${PYTHON_PKGNAMEPREFIX}django-mezzanine-filebrowser>=0.4.6:www/py-django-mezzanine-filebrowser \
+ ${PYTHON_PKGNAMEPREFIX}django-mezzanine-grappelli>=0.4.5:www/py-django-mezzanine-grappelli \
${PYTHON_PKGNAMEPREFIX}tzlocal>=1.0:devel/py-tzlocal \
${PYTHON_PKGNAMEPREFIX}bleach>=1.4:www/py-bleach \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.1.3:www/py-beautifulsoup \
${PYTHON_PKGNAMEPREFIX}requests>=2.1.0:www/py-requests \
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0.4:www/py-requests-oauthlib \
${PYTHON_PKGNAMEPREFIX}future>=0.9.0:devel/py-future \
- ${PYTHON_PKGNAMEPREFIX}pillow>=1.3.1:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}django-contrib-comments>0:www/py-django-contrib-comments \
- ${PYTHON_PKGNAMEPREFIX}south>=0.7.3:databases/py-south \
-
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}chardet>0:textproc/py-chardet
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pep8>=1.4.1:devel/pep8 \
${PYTHON_PKGNAMEPREFIX}pyflakes>=0.6.1:devel/py-pyflakes
USES= gettext python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
do-test:
@cd ${WRKSRC} && ${SETENV} TZ=UTC LC_ALL=en_US.UTF-8 ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/www/py-django-mezzanine/distinfo b/www/py-django-mezzanine/distinfo
index 61029c64586e..79680c345785 100644
--- a/www/py-django-mezzanine/distinfo
+++ b/www/py-django-mezzanine/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Mezzanine-3.1.10.tar.gz) = cd33d3dce112ae24fbb23ab2632334d124d3c35556fd2a3d87ec5916293a1705
-SIZE (Mezzanine-3.1.10.tar.gz) = 7430509
+TIMESTAMP = 1477385624
+SHA256 (Mezzanine-4.2.2.tar.gz) = 890298ec6e3281cce0b318a7956222480aa3be38bf25e8f841d9f5e33b7fba9b
+SIZE (Mezzanine-4.2.2.tar.gz) = 6229423
diff --git a/www/py-django-mezzanine/files/patch-setup.py b/www/py-django-mezzanine/files/patch-setup.py
deleted file mode 100644
index 8164d393950d..000000000000
--- a/www/py-django-mezzanine/files/patch-setup.py
+++ /dev/null
@@ -1,27 +0,0 @@
---- setup.py.orig 2014-08-11 10:12:36 UTC
-+++ setup.py
-@@ -53,12 +53,12 @@ try:
- "django >= 1.4.10, != 1.6.0, < 1.7",
- "filebrowser_safe >= 0.3.4",
- "grappelli_safe >= 0.3.12",
-- "tzlocal == 1.0",
-+ "tzlocal >= 1.0",
- "bleach >= 1.4",
-- "beautifulsoup4 == 4.1.3",
-+ "beautifulsoup4 >= 4.1.3",
- "requests >= 2.1.0",
- "requests-oauthlib >= 0.4",
-- "future == 0.9.0",
-+ "future >= 0.9.0",
- "pillow",
- ],
- entry_points="""
-@@ -66,7 +66,7 @@ try:
- mezzanine-project=mezzanine.bin.mezzanine_project:create_project
- """,
- test_suite="mezzanine.bin.runtests.main",
-- tests_require=["pyflakes==0.6.1", "pep8==1.4.1"],
-+ tests_require=["pyflakes>=0.6.1", "pep8>=1.4.1"],
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Environment :: Web Environment",