aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-03-19 02:22:09 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-03-19 02:22:09 +0000
commit0ed591808251c90698026bfad8e45769418e3091 (patch)
treec5bb286d4eebc4313960a12f5f41f2be017ca8d1
parenta5572c76ef646153633c7f7619cbaea836844d3c (diff)
downloadports-0ed591808251c90698026bfad8e45769418e3091.tar.gz
ports-0ed591808251c90698026bfad8e45769418e3091.zip
MFH: r496214
print/lyx: Correct the python executable location in .py, .cpp, .lyx files; Add missing USExx clauses lyx was broken without being able to call the python executable. PR: 236619 Approved by: rakuco Approved by: ports-secteam
Notes
Notes: svn path=/branches/2019Q1/; revision=496238
-rw-r--r--print/lyx/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 99aa61ea17e5..6b167e926d05 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -3,8 +3,7 @@
PORTNAME= lyx
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
-DISTVERSIONSUFFIX= -2
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -20,14 +19,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libmythes-1.2.so:textproc/mythes
-WRKSRC= ${WRKDIR}/${DISTNAME:S,${DISTVERSIONSUFFIX}$$,,}
-
MAJOR_VERSION= 2.3
-MINOR_VERSION= 1
+MINOR_VERSION= 2
USES= compiler:c++11-lang desktop-file-utils gmake iconv pkgconfig \
perl5 python:2.7 qt:5 shebangfix tar:xz
-USE_QT= core concurrent gui svg widgets buildtools_build qmake_build
+USE_QT= core concurrent gui svg widgets x11extras buildtools_build qmake_build
+USE_XORG= xcb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
--without-included-mythes \
@@ -58,4 +56,7 @@ HUNSPELL_LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
+post-patch:
+ @${GREP} -rl "python -tt" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -i '' 's|python -tt|${PYTHON_CMD} -tt|'
+
.include <bsd.port.mk>