aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-17 18:47:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-17 18:47:04 +0000
commit4f7cc7c1ab99c4c99a53a7776dc37ef9170ac486 (patch)
tree041558b5715d71f7515cb2343fae95dfddaeb236
parent8aef669cb4b53f320e9a58cc63e684e3d3885ab1 (diff)
downloadports-4f7cc7c1ab99c4c99a53a7776dc37ef9170ac486.tar.gz
ports-4f7cc7c1ab99c4c99a53a7776dc37ef9170ac486.zip
MFH: r493213 r493610 r495827
Remove outdated comment The corresponding patches of the 2 ports which contain rubygems version have been replaced by REINPLACE_CMD command in r486416 and r486417. Update devel/ruby-gems to 3.0.2 - Update Mk/Uses/gem.mk Changes: https://github.com/rubygems/rubygems/blob/master/History.txt PR: 235795 Submitted by: Yasuhiro KIMURA <yasu@utahime.org>, sunpoet (myself) Exp-run by: antoine Update to 3.0.3 Changes: https://github.com/rubygems/rubygems/blob/master/History.txt Security: 27b12d04-4722-11e9-8b7c-b5e01141761f Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2019Q1/; revision=496088
-rw-r--r--Mk/Uses/gem.mk6
-rw-r--r--devel/ruby-gems/Makefile12
-rw-r--r--devel/ruby-gems/distinfo6
-rw-r--r--devel/ruby-gems/pkg-plist3
-rw-r--r--devel/rubygem-io-like/Makefile12
-rw-r--r--sysutils/vagrant/Makefile6
-rw-r--r--sysutils/vagrant/pkg-plist1
-rw-r--r--textproc/rubygem-cld3/Makefile2
8 files changed, 29 insertions, 19 deletions
diff --git a/Mk/Uses/gem.mk b/Mk/Uses/gem.mk
index 28a6466fd520..3d26a6febedf 100644
--- a/Mk/Uses/gem.mk
+++ b/Mk/Uses/gem.mk
@@ -74,9 +74,9 @@ GEMFILES= ${DISTNAME}${EXTRACT_SUFX}
RUBYGEM_ARGS=-l --no-update-sources --install-dir ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER} --ignore-dependencies --bindir=${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
-RUBYGEM_ARGS+= --rdoc --ri
+RUBYGEM_ARGS+= --document rdoc,ri
.else
-RUBYGEM_ARGS+= --no-rdoc --no-ri
+RUBYGEM_ARGS+= --no-document
.endif
.if !target(do-extract)
@@ -104,7 +104,7 @@ do-build:
.if !target(do-install)
do-install:
- (cd ${BUILD_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} ${GEMFILES} -- --build-args ${CONFIGURE_ARGS})
+ (cd ${BUILD_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} ${GEMFILES} -- ${CONFIGURE_ARGS})
${RM} -r ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR}/build_info/
${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -type f -name '*.so' -exec ${STRIP_CMD} {} +
${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -type f \( -name mkmf.log -or -name gem_make.out \) -delete
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index 53ae500fb793..11ed23d17214 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -2,12 +2,9 @@
# $FreeBSD$
PORTNAME= gems
-# Do not forget to check the following ports which contain gemspec patches:
-# - security/rubygem-ezcrypto
-# - www/rubygem-gitlab-grack
-PORTVERSION= 2.7.8
+PORTVERSION= 3.0.3
CATEGORIES= devel ruby
-MASTER_SITES= https://production.cf.rubygems.org/rubygems/
+MASTER_SITES= https://rubygems.org/rubygems/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
@@ -20,11 +17,12 @@ LICENSE_COMB= dual
LICENSE_FILE_MIT= ${WRKSRC}/MIT.txt
LICENSE_FILE_RUBY= ${WRKSRC}/LICENSE.txt
+USES= tar:tgz
+USE_RUBY= yes
+
NO_ARCH= yes
NO_BUILD= yes
-USE_RUBY= yes
RUBY_SETUP= setup.rb
-USES= tar:tgz
GEMS_BASE_DIR= lib/ruby/gems
GEMS_BASE_DIR_P= ${GEMS_BASE_DIR}
diff --git a/devel/ruby-gems/distinfo b/devel/ruby-gems/distinfo
index 2bb36deabeb4..e04e41adea3e 100644
--- a/devel/ruby-gems/distinfo
+++ b/devel/ruby-gems/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541353342
-SHA256 (ruby/rubygems-2.7.8.tgz) = f0d04b15a2dcf16c30895839366b0f0735651ade6cdaa424b15c0fe77e2fdf58
-SIZE (ruby/rubygems-2.7.8.tgz) = 920781
+TIMESTAMP = 1552063707
+SHA256 (ruby/rubygems-3.0.3.tgz) = be3a7abc31e91de667406e84cd15265b73fc502268a1dd09404214a49b4acb2c
+SIZE (ruby/rubygems-3.0.3.tgz) = 904175
diff --git a/devel/ruby-gems/pkg-plist b/devel/ruby-gems/pkg-plist
index 4e18588ed0b1..e00701d5638e 100644
--- a/devel/ruby-gems/pkg-plist
+++ b/devel/ruby-gems/pkg-plist
@@ -16,6 +16,7 @@ bin/gem%%RUBY_VER_SHORT%%
%%RUBY_SITELIBDIR%%/rubygems/commands/fetch_command.rb
%%RUBY_SITELIBDIR%%/rubygems/commands/generate_index_command.rb
%%RUBY_SITELIBDIR%%/rubygems/commands/help_command.rb
+%%RUBY_SITELIBDIR%%/rubygems/commands/info_command.rb
%%RUBY_SITELIBDIR%%/rubygems/commands/install_command.rb
%%RUBY_SITELIBDIR%%/rubygems/commands/list_command.rb
%%RUBY_SITELIBDIR%%/rubygems/commands/lock_command.rb
@@ -44,6 +45,7 @@ bin/gem%%RUBY_VER_SHORT%%
%%RUBY_SITELIBDIR%%/rubygems/config_file.rb
%%RUBY_SITELIBDIR%%/rubygems/core_ext/kernel_gem.rb
%%RUBY_SITELIBDIR%%/rubygems/core_ext/kernel_require.rb
+%%RUBY_SITELIBDIR%%/rubygems/core_ext/kernel_warn.rb
%%RUBY_SITELIBDIR%%/rubygems/defaults.rb
%%RUBY_SITELIBDIR%%/rubygems/dependency.rb
%%RUBY_SITELIBDIR%%/rubygems/dependency_installer.rb
@@ -165,6 +167,7 @@ bin/gem%%RUBY_VER_SHORT%%
%%RUBY_SITELIBDIR%%/rubygems/source_specific_file.rb
%%RUBY_SITELIBDIR%%/rubygems/spec_fetcher.rb
%%RUBY_SITELIBDIR%%/rubygems/specification.rb
+%%RUBY_SITELIBDIR%%/rubygems/specification_policy.rb
%%RUBY_SITELIBDIR%%/rubygems/ssl_certs/index.rubygems.org/GlobalSignRootCA.pem
%%RUBY_SITELIBDIR%%/rubygems/ssl_certs/rubygems.global.ssl.fastly.net/DigiCertHighAssuranceEVRootCA.pem
%%RUBY_SITELIBDIR%%/rubygems/ssl_certs/rubygems.org/AddTrustExternalCARoot.pem
diff --git a/devel/rubygem-io-like/Makefile b/devel/rubygem-io-like/Makefile
index 74c07bbdaa42..1e42b95d6b01 100644
--- a/devel/rubygem-io-like/Makefile
+++ b/devel/rubygem-io-like/Makefile
@@ -51,7 +51,7 @@ RAKE_BIN= ${LOCALBASE}/bin/rake
GEMFILES= ${GEM_NAME}.gem
-RUBYGEM_ARGS=-l --no-update-sources --no-ri --install-dir ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER} --ignore-dependencies --bindir=${STAGEDIR}${PREFIX}/bin
+RUBYGEM_ARGS= -l --no-update-sources --install-dir ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER} --ignore-dependencies --bindir=${STAGEDIR}${PREFIX}/bin
WRKSRC= ${WRKDIR}/${PORTNAME}-ruby-1.9-temp
@@ -60,6 +60,14 @@ OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= rubygem-allison>=0:devel/rubygem-allison
DOCS_VARS_OFF= RUBYGEM_ARGS+=--no-rdoc
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+RUBYGEM_ARGS+= --document rdoc,ri
+.else
+RUBYGEM_ARGS+= --no-document
+.endif
+
post-patch:
.for l in 1.8.6 1.8.7 1.9.2 1.9.3
@${ECHO} lib/io/like-${l}.rb >> ${WRKSRC}/MANIFEST
@@ -72,7 +80,7 @@ do-build:
@cd ${BUILD_WRKSRC} && ${RAKE_BIN}
do-install:
- @(cd ${INSTALL_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} pkg/${GEMFILES} -- --build-args ${CONFIGURE_ARGS})
+ @(cd ${INSTALL_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} pkg/${GEMFILES} -- ${CONFIGURE_ARGS})
@${RM} -r ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR}/build_info
@${RMDIR} ${STAGEDIR}/${PREFIX}/${GEMS_BASE_DIR}/extensions
diff --git a/sysutils/vagrant/Makefile b/sysutils/vagrant/Makefile
index b3d76eed9a6d..27405f0be340 100644
--- a/sysutils/vagrant/Makefile
+++ b/sysutils/vagrant/Makefile
@@ -4,6 +4,7 @@
PORTNAME= vagrant
PORTVERSION= 2.2.2
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= sysutils rubygems devel
MAINTAINER= joe@thrallingpenguin.com
@@ -54,7 +55,7 @@ PLIST_SUB+= GEMS_DIR="lib/ruby/gems/${RUBY_VER}/" \
PORTVERSION="${PORTVERSION}"
NO_ARCH= yes
-RUBYGEM_ARGS= --no-ri --no-rdoc -l --no-update-sources \
+RUBYGEM_ARGS= -l --no-document --no-update-sources \
--install-dir ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER} \
--ignore-dependencies --bindir=${STAGEDIR}${PREFIX}/bin
GEM_ENV+= RB_USER_INSTALL=yes
@@ -68,7 +69,8 @@ do-build:
${GEM_ENV} ${RUBYGEMBIN} build vagrant.gemspec)
(cd ${WRKSRC}; ${SETENV} VAGRANT_INSTALLER_ENV=yes \
${GEM_ENV} ${RUBYGEMBIN} install ${RUBYGEM_ARGS} \
- ${GEMFILES} -- --build-args ${CONFIGURE_ARGS})
+ ${GEMFILES} -- ${CONFIGURE_ARGS})
+ ${RMDIR} ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER}/build_info
${MKDIR} ${STAGEDIR}${DATADIR}/embedded/rgloader
${INSTALL_DATA} ${FILESDIR}/cacert.pem \
${STAGEDIR}${DATADIR}/embedded/cacert.pem
diff --git a/sysutils/vagrant/pkg-plist b/sysutils/vagrant/pkg-plist
index 1faca849b67b..2949d581909f 100644
--- a/sysutils/vagrant/pkg-plist
+++ b/sysutils/vagrant/pkg-plist
@@ -1,5 +1,4 @@
bin/vagrant
-%%GEMS_DIR%%build_info/vagrant-%%PORTVERSION%%.info
%%GEMS_DIR%%cache/vagrant-%%PORTVERSION%%.gem
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/.travis.yml
%%GEM_BASE_DIR%%/vagrant-%%PORTVERSION%%/.vimrc
diff --git a/textproc/rubygem-cld3/Makefile b/textproc/rubygem-cld3/Makefile
index 53ec0476de3a..2d1cd8e275d0 100644
--- a/textproc/rubygem-cld3/Makefile
+++ b/textproc/rubygem-cld3/Makefile
@@ -20,7 +20,7 @@ USE_RUBY= yes
## do-install here to prevent removal of ext
do-install:
(cd ${BUILD_WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install \
- ${RUBYGEM_ARGS} ${GEMFILES} -- --build-args ${CONFIGURE_ARGS})
+ ${RUBYGEM_ARGS} ${GEMFILES} -- ${CONFIGURE_ARGS})
${RM} -r ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR}/build_info/
${FIND} ${STAGEDIR}${PREFIX}/${GEMS_BASE_DIR} -type f -name '*.so' \
-exec ${STRIP_CMD} {} +