aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-03-25 07:34:59 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-03-25 07:34:59 +0000
commit9070eebd4fd3df4a3c83aaed64064c375f87e8ca (patch)
treec7083cb1726ded78f2a4198680ef98f9a1229442
parent60097679d79442ff5fc079974154c6740f4143af (diff)
downloadports-9070eebd4fd3df4a3c83aaed64064c375f87e8ca.tar.gz
ports-9070eebd4fd3df4a3c83aaed64064c375f87e8ca.zip
MFH: r489253 devel/py-buildbot: Version-suffix rc script command
For python ports, particularly those that use USE_PYTHON=concurrent, only the *default* python version/flavor (of the port) gets symlinks created for any script/binary filenames installed in LOCALBASE/bin. For non-default Python versions/flavors of the port or package, *only* a version-suffixed script filename is installed. The devel/buildbot-worker rc script was fixed in ports r483022 [1] to use a version-suffixed script name. This change fixes the same for devel/py-buildbot, whos rc script currently fails to run due to trying to invoke a non-existent 'buildbot' script name for the non-default (!2.7) case. Since a port/package cannot know at run time, at any point what the default Python version currently is, or whether it has changed, Python ports *must* always and only refer to version-specific variants for everything, including the Python interpreter, script shebangs, commands, paths, etc, for the Python version they are currently being built with. PR: 234565, 227675 [1] Reported by: Andreas Sommer <andreas.sommer87 googlemail com> Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2019Q1/; revision=496797
-rw-r--r--devel/py-buildbot/Makefile5
-rw-r--r--devel/py-buildbot/files/buildbot.in2
2 files changed, 4 insertions, 3 deletions
diff --git a/devel/py-buildbot/Makefile b/devel/py-buildbot/Makefile
index bf4efa81e220..2b44ddcd214b 100644
--- a/devel/py-buildbot/Makefile
+++ b/devel/py-buildbot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= buildbot
PORTVERSION= 1.5.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -29,7 +30,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}treq>0:www/py-treq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=2.0.0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lz4>=0:archivers/py-lz4@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>0:devel/py-buildbot-pkg@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}buildbot-pkg>0:devel/py-buildbot-pkg@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}pyjade>0:www/py-pyjade@${PY_FLAVOR}
# to be ported ${PYTHON_PKGNAMEPREFIX}moto>0:www/py-moto@${PY_FLAVOR}
@@ -37,7 +38,7 @@ USES= python
USE_RC_SUBR= buildbot
USE_PYTHON= autoplist concurrent distutils
-SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} PYTHON_VER=${PYTHON_VER}
NO_ARCH= yes
diff --git a/devel/py-buildbot/files/buildbot.in b/devel/py-buildbot/files/buildbot.in
index 8484223174b5..3f115dee4bdd 100644
--- a/devel/py-buildbot/files/buildbot.in
+++ b/devel/py-buildbot/files/buildbot.in
@@ -19,7 +19,7 @@ export PATH=${PATH}:%%PREFIX%%/bin
name="buildbot"
rcvar=buildbot_enable
-command="%%PREFIX%%/bin/buildbot"
+command="%%PREFIX%%/bin/buildbot-%%PYTHON_VER%%"
load_rc_config $name
check_cmd="${name}_check"