aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-03-25 07:48:26 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-03-25 07:48:26 +0000
commitdcafe0f711baabb0bba4df0253eb74d29badb1ab (patch)
treec2b6ba9a8bd04cffff73ca9b9fc8a06eda8b43f4
parente95bd2aad6c75fc9acdc5432ee27ee9654490efa (diff)
downloadports-dcafe0f711baabb0bba4df0253eb74d29badb1ab.tar.gz
ports-dcafe0f711baabb0bba4df0253eb74d29badb1ab.zip
MFH: r490937 www/py-requests: Update to 2.21.0
- Update USES comment (Python 3.3 support dropped) - Rebase setup.py patch (idna change released) - Remove comment about failing tests due to httpbin issue which seems to now be fixed. This update includes a pinned urllib3 version bump to < 1.25, which paves the way for a net/urllib3 update to 1.24 [1]. Note: 2.20.0 includes a security vulnerability fix for CVE-2018-18074 Changelog: https://github.com/requests/requests/blob/v2.21.0/HISTORY.md PR: 229322 [1] Security: 50ad9a9a-1e28-11e9-98d7-0050562a4d7b Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2019Q1/; revision=496799
-rw-r--r--www/py-requests/Makefile8
-rw-r--r--www/py-requests/distinfo6
-rw-r--r--www/py-requests/files/patch-setup.py27
3 files changed, 14 insertions, 27 deletions
diff --git a/www/py-requests/Makefile b/www/py-requests/Makefile
index 15821b8390f9..10391d726828 100644
--- a/www/py-requests/Makefile
+++ b/www/py-requests/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= requests
-PORTVERSION= 2.18.4
-PORTREVISION= 1
+PORTVERSION= 2.21.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -22,7 +21,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR}
-# Actually 2.6-2.7,3.3+
+# Actually 2.6-2.7,3.4+
USES= python
USE_PYTHON= autoplist concurrent distutils
@@ -30,9 +29,6 @@ CONFLICTS_INSTALL= py*-requests1-*
NO_ARCH= yes
-# Automated tests failinng due to httpbin issue
-# https://github.com/kennethreitz/httpbin/issues/403
-
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/www/py-requests/distinfo b/www/py-requests/distinfo
index 31d868f0849e..3affe0c5a814 100644
--- a/www/py-requests/distinfo
+++ b/www/py-requests/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1519435351
-SHA256 (requests-2.18.4.tar.gz) = 9c443e7324ba5b85070c4a818ade28bfabedf16ea10206da1132edaa6dda237e
-SIZE (requests-2.18.4.tar.gz) = 126224
+TIMESTAMP = 1548125465
+SHA256 (requests-2.21.0.tar.gz) = 502a824f31acdacb3a35b6690b5fbf0bc41d63a24a45c4004352b0242707598e
+SIZE (requests-2.21.0.tar.gz) = 111528
diff --git a/www/py-requests/files/patch-setup.py b/www/py-requests/files/patch-setup.py
index eee22c704530..21e1c6a6a81f 100644
--- a/www/py-requests/files/patch-setup.py
+++ b/www/py-requests/files/patch-setup.py
@@ -1,21 +1,12 @@
-# 1: Backport bumping idna max version
-# https://github.com/requests/requests/commit/991e8b76b7a9d21f698b24fa0058d3d5968721bc
-# 2: pytest-cov and its dependencies are not compulsory
+# pytest-cov and its dependencies are not compulsory
---- setup.py.orig 2017-08-15 13:19:39 UTC
+--- setup.py.orig 2019-01-22 02:52:54 UTC
+++ setup.py
-@@ -43,12 +43,12 @@ packages = ['requests']
-
- requires = [
- 'chardet>=3.0.2,<3.1.0',
-- 'idna>=2.5,<2.7',
-+ 'idna>=2.5,<2.8',
- 'urllib3>=1.21.1,<1.23',
- 'certifi>=2017.4.17'
-
+@@ -50,7 +50,6 @@ requires = [
]
--test_requirements = ['pytest-httpbin==0.0.7', 'pytest-cov', 'pytest-mock', 'pytest-xdist', 'PySocks>=1.5.6, !=1.5.7', 'pytest>=2.8.0']
-+test_requirements = ['pytest-httpbin==0.0.7', 'pytest-mock', 'pytest-xdist', 'PySocks>=1.5.6, !=1.5.7', 'pytest>=2.8.0']
-
- about = {}
- with open(os.path.join(here, 'requests', '__version__.py'), 'r', 'utf-8') as f:
+ test_requirements = [
+ 'pytest-httpbin==0.0.7',
+- 'pytest-cov',
+ 'pytest-mock',
+ 'pytest-xdist',
+ 'PySocks>=1.5.6, !=1.5.7',