aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2021-06-08 06:23:58 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2021-06-08 06:31:00 +0000
commitf778c82958cd5a23d1ad29076b122600ec37deb1 (patch)
tree65be4b05dfcff4f4d2196c382f1fc3be82706874
parentef55dcb4849d2be1780e4a272db1cf7e2c8afccc (diff)
downloadports-f778c82958cd5a23d1ad29076b122600ec37deb1.tar.gz
ports-f778c82958cd5a23d1ad29076b122600ec37deb1.zip
lang/sbcl: update to 2.1.5
(cherry picked from commit e91a8dfb87df5b0c0fb0d659a9beb9c0d9cf9c24)
-rw-r--r--lang/sbcl/Makefile2
-rw-r--r--lang/sbcl/distinfo10
-rw-r--r--lang/sbcl/files/patch-src_compiler_ir1tran.lisp20
3 files changed, 6 insertions, 26 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index a9b7b7f0dc7d..b06615b5b685 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -4,7 +4,7 @@
# pinned to exact versions of everything used to build them.
PORTNAME= sbcl
-DISTVERSION= 2.1.4
+DISTVERSION= 2.1.5
DISTVERSIONSUFFIX= -source
PORTEPOCH= 1
CATEGORIES= lang lisp
diff --git a/lang/sbcl/distinfo b/lang/sbcl/distinfo
index 1a775e462b20..d4db64776208 100644
--- a/lang/sbcl/distinfo
+++ b/lang/sbcl/distinfo
@@ -1,8 +1,8 @@
-TIMESTAMP = 1619707316
-SHA256 (sbcl-2.1.4-source.tar.bz2) = 99260e2346fcd22ae5546e15baf50899dcb3b75a6c74cc7cc849378899efbd11
-SIZE (sbcl-2.1.4-source.tar.bz2) = 6550812
-SHA256 (sbcl-2.1.4-documentation-html.tar.bz2) = 6f707343c8eb501f884cced657477f23d5a75c491f77797f395254f178ad730e
-SIZE (sbcl-2.1.4-documentation-html.tar.bz2) = 232216
+TIMESTAMP = 1623132979
+SHA256 (sbcl-2.1.5-source.tar.bz2) = 965807ecd65a9590d68a0ed408b544e7e49a1f6e337ebd2b25e34788bcc8a8c5
+SIZE (sbcl-2.1.5-source.tar.bz2) = 6566902
+SHA256 (sbcl-2.1.5-documentation-html.tar.bz2) = 42b53afd9355c69541be73bf648047d6aa88d0001526b84d643517b5dbafcb27
+SIZE (sbcl-2.1.5-documentation-html.tar.bz2) = 232259
SHA256 (sbcl-1.2.7-x86-64-freebsd-binary.tar.bz2) = c61f5e777e56921d2452d0fa6b71024ccd9b99bc659676498d398b8663176492
SIZE (sbcl-1.2.7-x86-64-freebsd-binary.tar.bz2) = 10463348
SHA256 (sbcl-1.2.7-x86-freebsd-binary.tar.bz2) = cf68bfab780a14964d9593f5b47fa3e174cf43e95ae3e558712d218f1c37bdbe
diff --git a/lang/sbcl/files/patch-src_compiler_ir1tran.lisp b/lang/sbcl/files/patch-src_compiler_ir1tran.lisp
deleted file mode 100644
index 03a66d0241e3..000000000000
--- a/lang/sbcl/files/patch-src_compiler_ir1tran.lisp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/compiler/ir1tran.lisp.orig 2021-04-28 20:54:30 UTC
-+++ src/compiler/ir1tran.lisp
-@@ -329,7 +329,7 @@
- ;;; CONSTANT might be circular. We also check that the constant (and
- ;;; any subparts) are dumpable at all.
- (defun ensure-externalizable (constant)
-- (declare (inline alloc-xset))
-+ (declare #-sb-xc-host (inline alloc-xset))
- (dx-let ((xset (alloc-xset)))
- (named-let grovel ((value constant))
- ;; Unless VALUE is an object which which can't contain other objects,
-@@ -386,7 +386,7 @@
- ;;; A constant is trivially externalizable if it involves no INSTANCE types
- ;;; or any un-dumpable object.
- (defun trivially-externalizable-p (constant)
-- (declare (inline alloc-xset))
-+ (declare #-sb-xc-host (inline alloc-xset))
- (dx-let ((xset (alloc-xset)))
- (named-let ok ((value constant))
- (if (or (dumpable-leaflike-p value) (xset-member-p value xset))