aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2022-09-21 14:37:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2022-09-21 15:17:51 +0000
commitde506faf165ae6e5719be7cea12bc5ed9e690237 (patch)
treedcacd022ed68eba998c620213e94c0f1ef9a9364
parentb43020f0a1544f7ea30363eb1f3d71f4dd01de11 (diff)
downloadports-de506faf165ae6e5719be7cea12bc5ed9e690237.tar.gz
ports-de506faf165ae6e5719be7cea12bc5ed9e690237.zip
dns/bind916: update to 9.16.33
Changes: https://downloads.isc.org/isc/bind9/9.16.33/doc/arm/html/notes.html#notes-for-bind-9-16-33 MFH: yes Security: CVE-2022-2795 CVE-2022-2881 CVE-2022-2906 CVE-2022-3080 CVE-2022-38177 CVE-2022-38178 (cherry picked from commit d6e108c34a97d1dddb1d1af1309b5f9cce0d6d00)
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
3 files changed, 10 insertions, 10 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index ffd84ee5e114..8e607ca1d2b5 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.31
+ISCVERSION= 9.16.33
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index aac5766b38af..4687d1b4ccec 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658484522
-SHA256 (bind-9.16.31.tar.xz) = 8ca2cb6c37b605c70f7a25f0cf8a94d2040e025824db2341b92625efd96e7cfb
-SIZE (bind-9.16.31.tar.xz) = 5087424
+TIMESTAMP = 1663770048
+SHA256 (bind-9.16.33.tar.xz) = ec4fbea4b2e368d1824971509e33fa159224ad14b436034c6bcd46104c328d91
+SIZE (bind-9.16.33.tar.xz) = 5092516
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index a16b3b16378c..6f64ab6d19c9 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2022-07-11 04:55:00 UTC
+--- bin/named/config.c.orig 2022-09-08 13:01:23 UTC
+++ bin/named/config.c
@@ -176,6 +176,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2022-07-11 04:55:00 UTC
+--- bin/named/server.c.orig 2022-09-08 13:01:23 UTC
+++ bin/named/server.c
@@ -4424,6 +4424,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2022-07-11 04:55:00 UTC
+--- lib/dns/include/dns/view.h.orig 2022-09-08 13:01:23 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2022-07-11 04:55:00 UTC
+--- lib/dns/resolver.c.orig 2022-09-08 13:01:23 UTC
+++ lib/dns/resolver.c
-@@ -6420,6 +6420,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6448,6 +6448,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2022-07-11 04:55:00 UTC
+--- lib/isccfg/namedconf.c.orig 2022-09-08 13:01:23 UTC
+++ lib/isccfg/namedconf.c
@@ -2051,6 +2051,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */