aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2022-12-23 16:06:54 +0000
committerMathieu Arnold <mat@FreeBSD.org>2022-12-23 16:33:12 +0000
commit059738844d03ae9c9771a609bc3c8e0931fa1a53 (patch)
tree76e44e2fc0a2a4a0b186e9f421b145a05395cf92
parent8e65e399fff101c33bd5389235dd61643e142b95 (diff)
downloadports-059738844d03ae9c9771a609bc3c8e0931fa1a53.tar.gz
ports-059738844d03ae9c9771a609bc3c8e0931fa1a53.zip
dns/bind916: update to 9.16.36
Changes: https://downloads.isc.org/isc/bind9/9.16.36/doc/arm/html/notes.html#notes-for-bind-9-16-36 (cherry picked from commit 06035627150e40d58299c61850b132b64b77a5eb)
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl16
3 files changed, 12 insertions, 12 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index 1fff6dcc34e0..7720db68a6bf 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.35
+ISCVERSION= 9.16.36
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 7b3d04bd3917..f55ad1acf8be 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1668616423
-SHA256 (bind-9.16.35.tar.xz) = 3e159617f182465c300a917eef880492c37183341b1091cc6654710c1d8d7b3e
-SIZE (bind-9.16.35.tar.xz) = 5102476
+TIMESTAMP = 1671811369
+SHA256 (bind-9.16.36.tar.xz) = 508c94e8c9884f6075fa820a51efae04a1758dbdd157b01695ea6cd07049c221
+SIZE (bind-9.16.36.tar.xz) = 5105696
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index f0f41817659b..9b4f3614413c 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2022-11-07 22:12:59 UTC
+--- bin/named/config.c.orig 2022-12-12 14:43:23 UTC
+++ bin/named/config.c
@@ -176,6 +176,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2022-11-07 22:12:59 UTC
+--- bin/named/server.c.orig 2022-12-12 14:43:23 UTC
+++ bin/named/server.c
-@@ -4426,6 +4426,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4437,6 +4437,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2022-11-07 22:12:59 UTC
+--- lib/dns/include/dns/view.h.orig 2022-12-12 14:43:23 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2022-11-07 22:12:59 UTC
+--- lib/dns/resolver.c.orig 2022-12-12 14:43:23 UTC
+++ lib/dns/resolver.c
-@@ -6456,6 +6456,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6494,6 +6494,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2022-11-07 22:12:59 UTC
+--- lib/isccfg/namedconf.c.orig 2022-12-12 14:43:23 UTC
+++ lib/isccfg/namedconf.c
-@@ -2051,6 +2051,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2053,6 +2053,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },