aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2022-12-24 06:00:52 +0000
committerGleb Popov <arrowd@FreeBSD.org>2022-12-24 06:07:26 +0000
commit5f2adb8a0bf84942dd97fbff202400d5fc0f52f0 (patch)
treecae9154cac472c87091dfd4fa22017aff596a1bf
parent0597389d2088390c09eb38f153ce532d131f2ddd (diff)
downloadports-5f2adb8a0bf84942dd97fbff202400d5fc0f52f0.tar.gz
ports-5f2adb8a0bf84942dd97fbff202400d5fc0f52f0.zip
Some Haskell ports: Mark BROKEN on aarch64.
These ports are failing on build cluster for some time. I tried reproducing it locally and it turned out to be a strange heisenbug - the compiler crashes when compiling different unrelated files and restarting the build makes the problem go away. I wasn't able to extract a minimal reproducing testcase, so didn't contact upstream. Mark BROKEN for now and hope for a new compiler version to work. Reported by: pkg-fallout (cherry picked from commit a84795fd56679424d0ddb67dab04e705df1e4b94)
-rw-r--r--devel/hs-git-annex/Makefile2
-rw-r--r--devel/hs-haskell-language-server/Makefile2
-rw-r--r--devel/stack/Makefile2
-rw-r--r--lang/purescript/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index df3ae04ef7ff..50c9b4efbe55 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -9,6 +9,8 @@ WWW= https://git-annex.branchable.com/
LICENSE= GPLv3
+BROKEN_aarch64= compiler crashes
+
BUILD_DEPENDS= rsync:net/rsync \
git:devel/git \
gsha256sum:sysutils/coreutils
diff --git a/devel/hs-haskell-language-server/Makefile b/devel/hs-haskell-language-server/Makefile
index fa2aaaf545f0..78b942976f9d 100644
--- a/devel/hs-haskell-language-server/Makefile
+++ b/devel/hs-haskell-language-server/Makefile
@@ -8,6 +8,8 @@ WWW= https://github.com/haskell/haskell-language-server/
LICENSE= APACHE20
+BROKEN_aarch64= compiler crashes
+
FLAVORS= default ghc810
FLAVOR?= ${FLAVORS:[1]}
.if ${FLAVOR:U} != default
diff --git a/devel/stack/Makefile b/devel/stack/Makefile
index f428ef744165..e8d19d8ec470 100644
--- a/devel/stack/Makefile
+++ b/devel/stack/Makefile
@@ -9,6 +9,8 @@ WWW= https://www.haskellstack.org/
LICENSE= BSD3CLAUSE
+BROKEN_aarch64= compiler crashes
+
RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss \
gmake:devel/gmake \
${LOCALBASE}/lib/compat/libffi.so.6:devel/libffi321 \
diff --git a/lang/purescript/Makefile b/lang/purescript/Makefile
index ae5c8eaeaaea..5f8d94333261 100644
--- a/lang/purescript/Makefile
+++ b/lang/purescript/Makefile
@@ -8,6 +8,8 @@ WWW= https://www.purescript.org/
LICENSE= BSD3CLAUSE
+BROKEN_aarch64= compiler crashes
+
USES= cabal
USE_LOCALE= en_US.UTF-8