aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-29 16:39:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-29 16:50:33 +0000
commit07ec86e98cf66240590ca94f13243a4738c42c81 (patch)
treeef210029aa7eac1d5cb767f001bc8a409b2b6ce3
parent7f2caba167477e84ff6ee7595ea743afbbb7d699 (diff)
downloadports-07ec86e98cf66240590ca94f13243a4738c42c81.tar.gz
ports-07ec86e98cf66240590ca94f13243a4738c42c81.zip
x11/wdisplays: unbreak build with textproc/py-scour
====> Checking for pkg-plist issues (check-plist) ===> Parsing plist ===> Checking for items in STAGEDIR missing from pkg-plist Error: Orphaned: share/icons/hicolor/scalable/apps/network.cycles.wdisplays.svg ===> Checking for items in pkg-plist which are not in STAGEDIR Error: Missing: share/icons/hicolor/scalable/apps/wdisplays.svg ===> Error: Plist issues found. *** Error code 1 PR: 270525 Reported by: Chad Jacob Milios (cherry picked from commit fdf37ec6360d430f2a71f85f85cc2e70ae7fc60f)
-rw-r--r--x11/wdisplays/Makefile3
-rw-r--r--x11/wdisplays/files/patch-resources_meson.build13
2 files changed, 15 insertions, 1 deletions
diff --git a/x11/wdisplays/Makefile b/x11/wdisplays/Makefile
index 37fb1f449ffe..3a34ec3ebee3 100644
--- a/x11/wdisplays/Makefile
+++ b/x11/wdisplays/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wdisplays
DISTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= x11 wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -23,6 +24,6 @@ USE_GNOME= cairo gtk30
GH_ACCOUNT= artizirk
PLIST_FILES= bin/${PORTNAME} \
share/applications/network.cycles.${PORTNAME}.desktop \
- share/icons/hicolor/scalable/apps/${PORTNAME}.svg
+ share/icons/hicolor/scalable/apps/network.cycles.${PORTNAME}.svg
.include <bsd.port.mk>
diff --git a/x11/wdisplays/files/patch-resources_meson.build b/x11/wdisplays/files/patch-resources_meson.build
new file mode 100644
index 000000000000..58810677480e
--- /dev/null
+++ b/x11/wdisplays/files/patch-resources_meson.build
@@ -0,0 +1,13 @@
+https://github.com/artizirk/wdisplays/pull/1
+
+--- resources/meson.build.orig 2021-03-29 08:33:43 UTC
++++ resources/meson.build
+@@ -37,7 +37,7 @@ if scour.found()
+ install: true,
+ install_dir: icondir)
+ else
+-install_data(icon, install_dir: icondir)
++install_data(icon, install_dir: icondir, rename: '@0@.svg'.format(meson.project_name()))
+ endif
+
+ install_data(