aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2023-03-23 16:02:35 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2023-03-23 16:03:20 +0000
commit84cf974efeed81c78636e1243d4653f774544958 (patch)
tree21e97290d3e835ae9068b48f438f7e15d72c7b6f
parentfda523b61a202989cccd8703d182dc7ed6138708 (diff)
downloadports-84cf974efeed81c78636e1243d4653f774544958.tar.gz
ports-84cf974efeed81c78636e1243d4653f774544958.zip
www/ungoogled-chromium: update to 111.0.5563.110
Approved by: rene (mentor) Security: https://vuxml.freebsd.org/freebsd/c8b334e0-6e83-4575-81d1-f9d5803ceb07.html (cherry picked from commit 4e8b33e768542234c57b4be1f583d93a37de690d)
-rw-r--r--www/ungoogled-chromium/Makefile3
-rw-r--r--www/ungoogled-chromium/distinfo14
-rw-r--r--www/ungoogled-chromium/files/patch-media_base_video__frame.cc12
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json519
4 files changed, 28 insertions, 20 deletions
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index c73557218838..0f13345198f3 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ungoogled-chromium
-PORTVERSION= 111.0.5563.64
-PORTREVISION= 1
+PORTVERSION= 111.0.5563.110
UGVERSION= ${DISTVERSION}-1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
diff --git a/www/ungoogled-chromium/distinfo b/www/ungoogled-chromium/distinfo
index 138cdfce1009..b9ff5eb7e9fe 100644
--- a/www/ungoogled-chromium/distinfo
+++ b/www/ungoogled-chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1678446139
-SHA256 (chromium-111.0.5563.64.tar.xz) = 7d5ca0e2bdb22a97713e6bfce74c651006d71aa883056c8e2c2a148039fe4074
-SIZE (chromium-111.0.5563.64.tar.xz) = 1740670460
-SHA256 (ungoogled-chromium-111.0.5563.64-1.tar.gz) = 2ad44997d95ae66b36125bf62bf1308006ec62da26ba04f8b5480d7271675079
-SIZE (ungoogled-chromium-111.0.5563.64-1.tar.gz) = 672674
-SHA256 (chromium-111.0.5563.64-testdata.tar.xz) = 944ddbc5c47541498d18f0f4d49d8dfe2f38c3553e8d589c1150748c6c7383eb
-SIZE (chromium-111.0.5563.64-testdata.tar.xz) = 263698728
+TIMESTAMP = 1679587017
+SHA256 (chromium-111.0.5563.110.tar.xz) = 49dd6c73b170a2dcf6edbb516cd9f77b550cc3d968f2097927c637015487a765
+SIZE (chromium-111.0.5563.110.tar.xz) = 1740800700
+SHA256 (ungoogled-chromium-111.0.5563.110-1.tar.gz) = 4593a09ba3222b82aeb95fd84b3346f86fab63b03cc8068501b336625b481d0e
+SIZE (ungoogled-chromium-111.0.5563.110-1.tar.gz) = 672671
+SHA256 (chromium-111.0.5563.110-testdata.tar.xz) = 9003084208f20affc418addc90e77a6022f2db2394517baad4a2ace6415b3598
+SIZE (chromium-111.0.5563.110-testdata.tar.xz) = 256039832
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/ungoogled-chromium/files/patch-media_base_video__frame.cc b/www/ungoogled-chromium/files/patch-media_base_video__frame.cc
index c5ade6ddf98d..0d440ca26e13 100644
--- a/www/ungoogled-chromium/files/patch-media_base_video__frame.cc
+++ b/www/ungoogled-chromium/files/patch-media_base_video__frame.cc
@@ -1,4 +1,4 @@
---- media/base/video_frame.cc.orig 2023-03-10 11:01:21 UTC
+--- media/base/video_frame.cc.orig 2023-03-22 09:35:28 UTC
+++ media/base/video_frame.cc
@@ -80,7 +80,7 @@ std::string VideoFrame::StorageTypeToString(
return "OWNED_MEMORY";
@@ -27,7 +27,7 @@
// This class allows us to embed a vector<ScopedFD> into a scoped_refptr, and
// thus to have several VideoFrames share the same set of DMABUF FDs.
class VideoFrame::DmabufHolder
-@@ -647,7 +647,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
+@@ -636,7 +636,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
for (size_t i = 0; i < num_planes; ++i)
planes[i].stride = gpu_memory_buffer->stride(i);
uint64_t modifier = gfx::NativePixmapHandle::kNoModifier;
@@ -36,7 +36,7 @@
if (gpu_memory_buffer->GetType() == gfx::NATIVE_PIXMAP) {
const auto gmb_handle = gpu_memory_buffer->CloneHandle();
if (gmb_handle.is_null() ||
-@@ -693,7 +693,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
+@@ -682,7 +682,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapExternalGpuM
return frame;
}
@@ -45,7 +45,7 @@
// static
scoped_refptr<VideoFrame> VideoFrame::WrapExternalDmabufs(
const VideoFrameLayout& layout,
-@@ -913,7 +913,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapVideoFrame(
+@@ -902,7 +902,7 @@ scoped_refptr<VideoFrame> VideoFrame::WrapVideoFrame(
}
}
@@ -54,7 +54,7 @@
DCHECK(frame->dmabuf_fds_);
// If there are any |dmabuf_fds_| plugged in, we should refer them too.
wrapping_frame->dmabuf_fds_ = frame->dmabuf_fds_;
-@@ -1304,7 +1304,7 @@ const gpu::MailboxHolder& VideoFrame::mailbox_holder(
+@@ -1293,7 +1293,7 @@ const gpu::MailboxHolder& VideoFrame::mailbox_holder(
: mailbox_holders_[texture_index];
}
@@ -63,7 +63,7 @@
const std::vector<base::ScopedFD>& VideoFrame::DmabufFds() const {
DCHECK_EQ(storage_type_, STORAGE_DMABUFS);
-@@ -1417,7 +1417,7 @@ VideoFrame::VideoFrame(const VideoFrameLayout& layout,
+@@ -1406,7 +1406,7 @@ VideoFrame::VideoFrame(const VideoFrameLayout& layout,
storage_type_(storage_type),
visible_rect_(Intersection(visible_rect, gfx::Rect(layout.coded_size()))),
natural_size_(natural_size),
diff --git a/www/ungoogled-chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5 b/www/ungoogled-chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
index 8ee9f8eecfc7..d775da04e674 100644
--- a/www/ungoogled-chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
+++ b/www/ungoogled-chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
@@ -1,6 +1,15 @@
---- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2023-03-10 11:01:21 UTC
+--- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2023-03-22 09:35:28 UTC
+++ third_party/blink/renderer/platform/runtime_enabled_features.json5
-@@ -1347,7 +1347,7 @@
+@@ -1127,7 +1127,7 @@
+ {
+ name: "DocumentPictureInPictureAPI",
+ origin_trial_feature_name: "DocumentPictureInPictureAPI",
+- origin_trial_os: ["win", "mac", "linux", "chromeos"],
++ origin_trial_os: ["win", "mac", "linux", "chromeos", "openbsd", "freebsd"],
+ status: {
+ "Android": "",
+ "ChromeOS_Lacros": "",
+@@ -1348,7 +1348,7 @@
depends_on: ["FileSystemAccessLocal"],
status: {"Android": "test", "default": "stable"},
origin_trial_feature_name: "FileHandling",
@@ -9,7 +18,7 @@
base_feature: "FileHandlingAPI",
},
{
-@@ -2933,7 +2933,7 @@
+@@ -2925,7 +2925,7 @@
{
name: "UnrestrictedSharedArrayBuffer",
origin_trial_feature_name: "UnrestrictedSharedArrayBuffer",
@@ -18,7 +27,7 @@
},
{
name: "URLPatternCompareComponent",
-@@ -2953,7 +2953,7 @@
+@@ -2945,7 +2945,7 @@
origin_trial_feature_name: "UserAgentReduction",
origin_trial_allows_third_party: true,
// iOS not included as it should not send a reduced User-Agent string.
@@ -27,7 +36,7 @@
base_feature: "ReduceUserAgent",
},
{
-@@ -3116,12 +3116,12 @@
+@@ -3108,12 +3108,12 @@
name: "WebAppUrlHandling",
status: "experimental",
origin_trial_feature_name: "WebAppUrlHandling",