aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-06-18 10:26:46 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-06-18 10:29:05 +0000
commit30d279cccdb743ffef6ba19f84b8f469fd0a3bfb (patch)
tree01e0ace0c961c5388c4c627d68cc498e7d2ab523
parent15aa9ea6ac296df7f91269d70e08c35a902cdc74 (diff)
downloadports-30d279cccdb743ffef6ba19f84b8f469fd0a3bfb.tar.gz
ports-30d279cccdb743ffef6ba19f84b8f469fd0a3bfb.zip
net/minidlna: Teach minidlna to handle .ass subtitle format.
(cherry picked from commit fd5e21bd97945073316f3a3fbd110c13ef3827ae)
-rw-r--r--net/minidlna/Makefile1
-rw-r--r--net/minidlna/files/patch-metadata.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 5bb84ea0f470..e846ae7f1958 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -1,5 +1,6 @@
PORTNAME= minidlna
PORTVERSION= 1.3.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net multimedia www
MASTER_SITES= SF
diff --git a/net/minidlna/files/patch-metadata.c b/net/minidlna/files/patch-metadata.c
new file mode 100644
index 000000000000..32b4bde4729b
--- /dev/null
+++ b/net/minidlna/files/patch-metadata.c
@@ -0,0 +1,14 @@
+--- metadata.c.orig 2022-08-30 05:42:54 UTC
++++ metadata.c
+@@ -146,6 +146,11 @@ check_for_captions(const char *path, int64_t detailID)
+ strcpy(p, ".smi");
+ ret = access(file, R_OK);
+ }
++ if (ret != 0)
++ {
++ strcpy(p, ".ass");
++ ret = access(file, R_OK);
++ }
+
+ if (ret == 0)
+ {