aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-09-28 01:41:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-28 01:42:47 +0000
commitd2613ebb18c4756dd5bd97f083bd55598b92aeb3 (patch)
tree368fffbe36f402aa6f69c007253531ae72fd84ff
parentdfde35f5c0e5b16288ed42c453893c5357530475 (diff)
downloadports-d2613ebb18c4756dd5bd97f083bd55598b92aeb3.tar.gz
ports-d2613ebb18c4756dd5bd97f083bd55598b92aeb3.zip
x11/xdg-desktop-portal-hyprland: unbreak build after e602fc540b59
meson.build:1:0: ERROR: Unable to detect linker for compiler `c++ -Wl,--version -fstack-protector-strong -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fexperimental-library -nostdinc++ -isystem/wrkdirs/usr/ports/x11/xdg-desktop-portal-hyprland/work-qt5/libcxx_prefix/include/c++/v1` stdout: stderr: c++: error: unknown argument: '-fexperimental-library' Reported by: pkg-fallout (direct commit to 2023Q3 as 4df0e66a3662 is missing on the branch)
-rw-r--r--x11/xdg-desktop-portal-hyprland/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11/xdg-desktop-portal-hyprland/Makefile b/x11/xdg-desktop-portal-hyprland/Makefile
index 7681b0d0acab..875637935447 100644
--- a/x11/xdg-desktop-portal-hyprland/Makefile
+++ b/x11/xdg-desktop-portal-hyprland/Makefile
@@ -58,8 +58,11 @@ post-configure:
.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
.if !exists(/usr/include/c++/v1/__ranges/as_rvalue_view.h) || make(makesum) || make(fetch)
BUILD_DEPENDS+= ${CMAKE_BIN}:devel/cmake-core
-USES+= llvm:min=16,build,export
+USES+= llvm:min=16,build
PATH:= ${LLVM_PREFIX}/bin:${PATH} # XXX _CMAKE_TOOLCHAIN_SUFFIX vs. devel/llvm*
+CC= clang${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
CMAKE_BIN= ${LOCALBASE}/bin/cmake