aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-09-27 14:05:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-27 14:20:23 +0000
commite602fc540b5956d9f82e4d37b697962b54f76d63 (patch)
tree69e01cfb92e8a6f5c8d36f722a355866c5b36a6b
parente6a0b4910ea6adba80ac4b484e359de6bdb9f39b (diff)
downloadports-e602fc540b5956d9f82e4d37b697962b54f76d63.tar.gz
ports-e602fc540b5956d9f82e4d37b697962b54f76d63.zip
x11/xdg-desktop-portal-hyprland: unbreak with Clang after 4ce3b4b71dcb
(cherry picked from commit 2944f5e8c102df462b3f898500ab9bcbec9e01c9)
-rw-r--r--x11/xdg-desktop-portal-hyprland/Makefile14
-rw-r--r--x11/xdg-desktop-portal-hyprland/distinfo2
2 files changed, 8 insertions, 8 deletions
diff --git a/x11/xdg-desktop-portal-hyprland/Makefile b/x11/xdg-desktop-portal-hyprland/Makefile
index f6a5a8d16903..7681b0d0acab 100644
--- a/x11/xdg-desktop-portal-hyprland/Makefile
+++ b/x11/xdg-desktop-portal-hyprland/Makefile
@@ -1,10 +1,12 @@
PORTNAME= xdg-desktop-portal-hyprland
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= x11 wayland
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 54b5467ec12f.patch:-p1 # https://github.com/hyprwm/xdg-desktop-portal-hyprland/pull/98
+PATCHFILES+= f9461b0b7d30.patch:-p1 # https://github.com/hyprwm/xdg-desktop-portal-hyprland/pull/100
MAINTAINER= jbeich@FreeBSD.org
COMMENT= xdg-desktop-portal backend for hyprland
@@ -27,7 +29,7 @@ qt5_CONFLICTS_INSTALL= ${PORTNAME}-qt6
qt6_CONFLICTS_INSTALL= ${PORTNAME}
qt6_PKGNAMESUFFIX= -qt6
-USES= compiler:gcc-c++11-lib gl meson pkgconfig
+USES= compiler:c++11-lib gl meson pkgconfig
USE_GITHUB= yes
USE_GL= gbm
GH_ACCOUNT= hyprwm
@@ -39,9 +41,7 @@ PLIST_FILES= libexec/${PORTNAME} \
# XXX Drop after FreeBSD 14.0 EOL around 2025-03-01
.if exists(/usr/lib/libc++.so) && !exists(/usr/include/c++/v1/__format/write_escaped.h)
-# Emulate -fexperimental-library for GCC
-CXXFLAGS+= -D_LIBCPP_ENABLE_EXPERIMENTAL # std::vformat
-LDFLAGS+= -lc++experimental
+CXXFLAGS+= -fexperimental-library
.endif
post-patch:
@@ -58,6 +58,8 @@ post-configure:
.if ${CXX} == c++ && exists(/usr/lib/libc++.so)
.if !exists(/usr/include/c++/v1/__ranges/as_rvalue_view.h) || make(makesum) || make(fetch)
BUILD_DEPENDS+= ${CMAKE_BIN}:devel/cmake-core
+USES+= llvm:min=16,build,export
+PATH:= ${LLVM_PREFIX}/bin:${PATH} # XXX _CMAKE_TOOLCHAIN_SUFFIX vs. devel/llvm*
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
CMAKE_BIN= ${LOCALBASE}/bin/cmake
@@ -78,7 +80,3 @@ bundled-libcxx:
.endif # exists(/usr/lib/libc++.so)
.include <bsd.port.mk>
-
-# XXX USES=compiler:gcc-c++11-lib
-RUN_DEPENDS:= ${RUN_DEPENDS:Ngcc*}
-LDFLAGS+= -static-libgcc
diff --git a/x11/xdg-desktop-portal-hyprland/distinfo b/x11/xdg-desktop-portal-hyprland/distinfo
index 08010d9d71ea..060f20907dfb 100644
--- a/x11/xdg-desktop-portal-hyprland/distinfo
+++ b/x11/xdg-desktop-portal-hyprland/distinfo
@@ -7,3 +7,5 @@ SHA256 (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = b5a9ff1793b1e2d388a3819bf
SIZE (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = 179289803
SHA256 (54b5467ec12f.patch) = 2cacc5de7b4b72410b9d338377ee51927fdc61918bf4657dd4c03eda7e56b34f
SIZE (54b5467ec12f.patch) = 2818
+SHA256 (f9461b0b7d30.patch) = 278adb116da65a783c8c1f103e2c6b3da8de413618cd7a3ced50f27c1a66f07e
+SIZE (f9461b0b7d30.patch) = 6421