aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2023-11-21 17:03:38 +0000
committerAlan Somers <asomers@FreeBSD.org>2023-12-27 22:42:10 +0000
commit21ef50a5d82decbe80c5f5ffc0b0505a8316a449 (patch)
treea01c45191fcfdca2ddfb9df54efb043c4ff33666
parent6f10f403deab66e1b35e145ba15adad89f265fbe (diff)
downloadports-21ef50a5d82decbe80c5f5ffc0b0505a8316a449.tar.gz
ports-21ef50a5d82decbe80c5f5ffc0b0505a8316a449.zip
net/nss_ldap: fix the build on both 13.2 and 14.0+
The original configure script attempted to detect the presence of Heimdal, but it failed with LLVM 15+ due to a type casting bug. commit 515552b2d2664dc02c2385519a7fedb855f46632 fixed the bug with LLVM 15+, but inadvertently broke the build for earlier versions. This commit corrects the configure syntax, fixing the build on 12.4 and 13.2. PR: 270465 Approved by: mikael (ports) Sponsored by: Axcient MFH: 2023Q4 (cherry picked from commit 512a940c48dfe70cf7fee96af994bad46e44eae9)
-rw-r--r--net/nss_ldap/files/patch-configure.in15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/nss_ldap/files/patch-configure.in b/net/nss_ldap/files/patch-configure.in
index 223ab338eff2..85364c26d5b0 100644
--- a/net/nss_ldap/files/patch-configure.in
+++ b/net/nss_ldap/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2009-11-06 02:28:08.000000000 -0800
-+++ configure.in 2023-05-09 21:54:34.360457000 -0700
-@@ -97,11 +97,15 @@
+--- configure.in.orig 2009-11-06 10:28:08 UTC
++++ configure.in
+@@ -97,11 +97,15 @@ esac
linux*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic -Wl,--version-script,\$(srcdir)/exports.linux" ;;
*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic" ;;
esac
@@ -16,7 +16,7 @@
AM_CONDITIONAL(USE_NATIVE_LINKER, test -n "$nss_ldap_so_LD")
-@@ -153,7 +157,6 @@
+@@ -153,7 +157,6 @@ case "$target_os" in
aix*) AC_CHECK_HEADERS(irs.h usersec.h) ;;
hpux*) AC_CHECK_HEADERS(nsswitch.h) ;;
*) AC_CHECK_HEADERS(nss.h)
@@ -24,14 +24,13 @@
AC_CHECK_HEADERS(irs.h) ;;
esac
AC_CHECK_HEADERS(thread.h)
-@@ -188,6 +191,14 @@
+@@ -188,6 +191,13 @@ AC_CHECK_HEADERS(krb5.h)
AC_CHECK_HEADERS(gssapi/gssapi_krb5.h gssapi.h)
AC_CHECK_HEADERS(krb5.h)
+AC_MSG_CHECKING([if Kerberos is Heimdal])
+AC_TRY_LINK([#include <krb5.h>],
-+ [char hv = heimdal_version;],
-+ [hv = hv;],
++ [const char *hv = heimdal_version;],
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE(HEIMDAL,1,[Define if Kerberos is Heimdal])],
+ [AC_MSG_RESULT(no)])
@@ -39,7 +38,7 @@
AC_CHECK_LIB(resolv, main)
AC_CHECK_LIB(nsl, main)
AC_CHECK_LIB(socket, main)
-@@ -230,7 +241,6 @@
+@@ -230,7 +240,6 @@ AC_CHECK_LIB(pthread_nonshared, main)
AC_CHECK_FUNCS(gethostbyname)
AC_CHECK_FUNCS(nsdispatch)
AC_CHECK_LIB(pthread_nonshared, main)