aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2023-12-25 16:15:08 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2023-12-25 16:22:16 +0000
commit2245103f43c99d592f4e78e3b0621ac3b0755f83 (patch)
tree43327a0b8e3b2cb5778e5f0dd3fb221ad4d0f47f
parent1edb590104da84fdcbe9c916f513a1aebacbaac5 (diff)
downloadports-2245103f43c99d592f4e78e3b0621ac3b0755f83.tar.gz
ports-2245103f43c99d592f4e78e3b0621ac3b0755f83.zip
www/phpvirtualbox{,-legacy}: PHP 8.2 support
Was fixed: 1. Deprecated: Creation of dynamic property vboxconnector::$client is deprecated in /usr/local/www/phpvirtualbox/endpoints/lib/vboxconnector.php on line 175. 2. Deprecated: Creation of dynamic property phpVBoxConfigClass::$enableHDFlushConfig is deprecated in /usr/local/www/phpvirtualbox/endpoints/lib/config.php on line 1825. 3. Deprecated: Creation of dynamic property phpVBoxConfigClass::$authMaster is deprecated in /usr/local/www/phpvirtualbox/endpoints/lib/config.php on line 241. 4. Division by zero in endpoints/lib/vboxconnector.php. Upstream issue: https://github.com/usvn/usvn/issues/82 Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D43175 MFH: 2023Q4 (cherry picked from commit 1c0edfc75b4b1d3620cfb25407bc4baaaa1c711f)
-rw-r--r--www/phpvirtualbox-legacy/Makefile2
-rw-r--r--www/phpvirtualbox/Makefile2
-rw-r--r--www/phpvirtualbox/files/patch-php834
3 files changed, 36 insertions, 2 deletions
diff --git a/www/phpvirtualbox-legacy/Makefile b/www/phpvirtualbox-legacy/Makefile
index ba80ba721ec8..be0c78bb5205 100644
--- a/www/phpvirtualbox-legacy/Makefile
+++ b/www/phpvirtualbox-legacy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= phpvirtualbox
DISTVERSION= 5.2-1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
PKGNAMESUFFIX= -legacy
diff --git a/www/phpvirtualbox/Makefile b/www/phpvirtualbox/Makefile
index cc67954d33a0..7569c308c855 100644
--- a/www/phpvirtualbox/Makefile
+++ b/www/phpvirtualbox/Makefile
@@ -1,6 +1,6 @@
PORTNAME= phpvirtualbox
DISTVERSION= 6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= vbox@FreeBSD.org
diff --git a/www/phpvirtualbox/files/patch-php8 b/www/phpvirtualbox/files/patch-php8
index 477a1596ba4c..12783b19f800 100644
--- a/www/phpvirtualbox/files/patch-php8
+++ b/www/phpvirtualbox/files/patch-php8
@@ -207,3 +207,37 @@ diff -ur panes/settingsNetwork.html.orig panes/settingsNetwork.html
$(nsel).jec();
}
+--- endpoints/lib/config.php.orig
++++ endpoints/lib/config.php
+@@ -141,6 +141,10 @@
+ */
+ var $eventListenerTimeout = 20;
+
++ var $enableHDFlushConfig = false;
++
++ var $authMaster = false;
++
+ /**
+ * Read user configuration, apply defaults, and do some sanity checking
+ * @see vboxconnector
+--- endpoints/lib/vboxconnector.php.orig
++++ endpoints/lib/vboxconnector.php
+@@ -112,6 +112,8 @@
+ */
+ var $dsep = null;
+
++ var $client = null;
++
+ /**
+ * Obtain configuration settings and set object vars
+ * @param boolean $useAuthMaster use the authentication master obtained from configuration class
+@@ -389,7 +389,8 @@
+
+ // The amount of time we will wait for events is determined by
+ // the amount of listeners - at least half a second
+- $listenerWait = max(100,intval(500/count($this->persistentRequest['vboxEventListeners'])));
++ $listenerCount = count($this->persistentRequest['vboxEventListeners']);
++ $listenerWait = max(100,intval(500/($listenerCount > 0 ? $listenerCount : 1)));
+ }
+
+ // Get events from each configured event listener