aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2024-03-22 20:49:01 +0000
committerDimitry Andric <dim@FreeBSD.org>2024-04-06 17:26:12 +0000
commit154a19da2a20a6f899d7e1e92c1ddc56447a0b00 (patch)
treea07861067142841607a92ac7c8fcfa0126c7689d
parent07eb689e5440197736a97954e223bf917bb6090d (diff)
downloadports-154a19da2a20a6f899d7e1e92c1ddc56447a0b00.tar.gz
ports-154a19da2a20a6f899d7e1e92c1ddc56447a0b00.zip
databases/mysql80-server databases/mysql81-server: fix build with libc++ 18 on i386
When building against libc++ 18, several iostream classes now get inlined into C++ binaries for efficiency. But because the mysql ports use -malign-double on non-powerpc architectures, this causes an ABI problem with libc++.so, which has not been built with that flag, at least on i386. This can cause segfaults during the build of the port. If it is not the architecture default, as it is on amd64, -malign-double should not be used without recompiling basically the entire userspace runtime. Quoting the gcc docs: > Warning: if you use the -malign-double switch, structures containing > the above types are aligned differently than the published application > binary interface specifications for the x86-32 and are not binary > compatible with structures in code compiled without that switch. Hence, remove -malign-double from CXXFLAGS for these ports. PR: 277896 Approved by: maintainer timeout (2 weeks) MFH: 2024Q1 (cherry picked from commit b49518c5c7c16418d7da0a5ce786da139b905bb1)
-rw-r--r--databases/mysql80-server/Makefile1
-rw-r--r--databases/mysql81-server/Makefile1
2 files changed, 0 insertions, 2 deletions
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index 8053ff41f708..a729a8155f68 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -189,7 +189,6 @@ SSP_UNSAFE= yes
LDFLAGS+= -latomic
USES+= compiler:gcc-c++11-lib
.else
-CXXFLAGS+= -malign-double
USES+= compiler:c++17-lang
.endif
diff --git a/databases/mysql81-server/Makefile b/databases/mysql81-server/Makefile
index dc321e3067ea..8e1a1ab072de 100644
--- a/databases/mysql81-server/Makefile
+++ b/databases/mysql81-server/Makefile
@@ -189,7 +189,6 @@ SSP_UNSAFE= yes
LDFLAGS+= -latomic
USES+= compiler:gcc-c++11-lib
.else
-CXXFLAGS+= -malign-double
USES+= compiler:c++17-lang
.endif