aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-02-07 10:38:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 07:14:20 +0000
commitf16fc5f6756361e87cc7ab9bed05c54ff919e0a5 (patch)
tree600be429c16bc9f1824a6ddf75f9b03457337ffa
parentfbf8ea82715adbe859c1c820ca74de08df9873de (diff)
downloadports-f16fc5f6756361e87cc7ab9bed05c54ff919e0a5.tar.gz
ports-f16fc5f6756361e87cc7ab9bed05c54ff919e0a5.zip
databases/tiledb: fix build on non-amd64
1. Fix build on powerpc by adding -Wno-c++11-narrowing. 2. Disable AVX2 by default since only modern amd64 supports it. (cherry picked from commit b4346f9b28adee34ea6de88fc21dd7039c032e87)
-rw-r--r--databases/tiledb/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/tiledb/Makefile b/databases/tiledb/Makefile
index 46fd44295d64..9332302382d2 100644
--- a/databases/tiledb/Makefile
+++ b/databases/tiledb/Makefile
@@ -28,9 +28,10 @@ RUN_DEPENDS= capnproto1>=1.0.1:devel/capnproto1 \
USES= cmake compiler:c++17-lang localbase:ldflags pkgconfig ssl
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
-CFLAGS_armv6+= -Wno-c++11-narrowing
-CFLAGS_armv7+= -Wno-c++11-narrowing
-CFLAGS_i386+= -Wno-c++11-narrowing
+CFLAGS_armv6= -Wno-c++11-narrowing
+CFLAGS_armv7= -Wno-c++11-narrowing
+CFLAGS_i386= -Wno-c++11-narrowing
+CFLAGS_powerpc= -Wno-c++11-narrowing
CMAKE_ARGS= -DCATCH_INCLUDE_DIR=${LOCALBASE}/include/catch2 \
-DFREEBSD_OPENSSLBASE=${OPENSSLBASE} \
-Dlibmagic_DICTIONARY=/usr/share/misc/magic.mgc
@@ -69,7 +70,6 @@ GH_PROJECT= TileDB
USE_GITHUB= yes
OPTIONS_DEFINE= AVX2
-OPTIONS_DEFAULT=AVX2
AVX2_DESC= AVX2 instructions support
AVX2_CMAKE_BOOL= COMPILER_SUPPORTS_AVX2