aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-05-15 03:34:26 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-05-15 03:36:00 +0000
commit35b4d1f670d897a7e8614df4f5e19da521208c5a (patch)
tree08324892837b372527736b84c6342760808897e0
parent93f305d4884c9841d8f6f4ebe5901459a8093aec (diff)
downloadports-35b4d1f670d897a7e8614df4f5e19da521208c5a.tar.gz
ports-35b4d1f670d897a7e8614df4f5e19da521208c5a.zip
lang/python27: Fix build with 'DEFAULT_VERSIONS=ssl=openssl'
Reported by: Odhiambo Washington Approved by: portmgr blanket (just fix it) MFH: 2024Q2 (cherry picked from commit 69ce5e29a540b5550a269d18651fdea2b7c79eda)
-rw-r--r--lang/python27/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 44c4fa1ed2c1..9f8d453d4424 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -121,7 +121,8 @@ post-patch:
# openssl/opensslv.h so setup.py just detects the string as 00000000
# However care should be taken for the OSVERSION. If OpenSSL 3.0.9
# lands later the OSVERSION string should be fixed accordingly
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || ${SSL_DEFAULT:Mopenssl3*} )
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || \
+ ${SSL_DEFAULT} == openssl || ${SSL_DEFAULT:Mopenssl3*} )
@${REINPLACE_CMD} -e 's|00907000|00000000|' \
${WRKSRC}/setup.py
.endif