aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2024-04-18 08:54:08 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2024-04-30 06:13:54 +0000
commit3aff86e62eb4e89214f25aed97e138e017ed6085 (patch)
tree97bab0b0ebead055cbdc8fa37824e8695068e92b
parent65444491e5816133acce7a908ec606d7a3f58828 (diff)
downloadports-3aff86e62eb4e89214f25aed97e138e017ed6085.tar.gz
ports-3aff86e62eb4e89214f25aed97e138e017ed6085.zip
graphics/mesa-libs: Fix LIB_DEPENDS
Mesa itself does not depend on libOpenGL.so from libglvnd but it needs libglvnd at build stage. Also it doesn't not depend on libwayland-egl.so but on libwayland-server.so and libwayland-client.so Differential Revision: https://reviews.freebsd.org/D44831 PR: 278324 Reported by: autodep Reviewed by: bapt Sponsored by: Beckhoff Automation GmbH & Co. KG (cherry picked from commit 171cdaf295e37c781f9a4999b05ea74da0bcd0f0)
-rw-r--r--graphics/mesa-libs/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index f8be1f1ef6db..a3d6cfd472e4 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mesa-libs
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= OpenGL libraries that support GLX and EGL clients
@@ -10,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/docs/license.rst
USES= llvm:noexport
-LIB_DEPENDS= libOpenGL.so:graphics/libglvnd
+BUILD_DEPENDS= libglvnd>=0:graphics/libglvnd
OPTIONS_GROUP= PLATFORM
OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND
@@ -24,7 +25,7 @@ OPTIONS_SUB= yes
WAYLAND_DESC= Enable support for the Wayland platform in EGL
WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
-WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
+WAYLAND_LIB_DEPENDS= libwayland-server.so:graphics/wayland
WAYLAND_IMPLIES= PLATFORM_WAYLAND
ZSTD_DESC= Use ZSTD for shader cache