aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-05-01 12:15:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-05-01 14:29:35 +0000
commit45d28cff1b0b68ac02c3e544db9d79ee80c5843b (patch)
tree6b4dd4c0629bd258a1d22f0f7e8322a17d04ed1a
parent410ef5f336a57f6e0aa577e92054b729ffb0e9f1 (diff)
downloadports-45d28cff1b0b68ac02c3e544db9d79ee80c5843b.tar.gz
ports-45d28cff1b0b68ac02c3e544db9d79ee80c5843b.zip
devel/busd: unbreak without XDG_RUNTIME_DIR
$ busd Error: No such file or directory (os error 2) $ truss busd [...] socket(PF_LOCAL,SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK,0) = 9 (0x9) bind(9,{ AF_UNIX "/run/user/1234/busd-session" },30) ERR#2 'No such file or directory' [...] May still fail if /var/run/user doesn't exist e.g., if neither pam_xdg nor consolekit2 are installed. FreeBSD >= 14.1 always sets XDG_RUNTIME_DIR. (cherry picked from commit 8b8f18da222dc7c8a23c73bf40f9d09924e436ea)
-rw-r--r--devel/busd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/busd/Makefile b/devel/busd/Makefile
index a9b3f8805a5f..e84bf9cc22f3 100644
--- a/devel/busd/Makefile
+++ b/devel/busd/Makefile
@@ -1,6 +1,6 @@
PORTNAME= busd
DISTVERSION= 0.2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
@@ -15,4 +15,9 @@ USE_GITHUB= yes
GH_ACCOUNT= dbus2
PLIST_FILES= bin/${PORTNAME}
+post-patch:
+# Respect consolekit2 as XDG_RUNTIME_DIR fallback
+ @${REINPLACE_CMD} 's,/run,/var&,' \
+ ${WRKSRC}/src/bus/mod.rs
+
.include <bsd.port.mk>