aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:12:16 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:32:06 +0000
commit5cf7541407a0a81906720417c1ec22ebde519960 (patch)
tree8670afe6f004571b2da5683453a7fc0fe93ca5ba
parent52630f65e60880ff2e5b996337ef5f018e9125dd (diff)
downloadports-5cf7541407a0a81906720417c1ec22ebde519960.tar.gz
ports-5cf7541407a0a81906720417c1ec22ebde519960.zip
graphics/glfw: fix build with EXAMPLES enabled and PREEDIT disabled
Both options are non-default. MFH: 2024Q2 (cherry picked from commit 0bcd20b238ac35ec0db95a496b8c9ce7b6015b4e)
-rw-r--r--Mk/Uses/mysql.mk4
-rw-r--r--graphics/glfw/Makefile4
2 files changed, 5 insertions, 3 deletions
diff --git a/Mk/Uses/mysql.mk b/Mk/Uses/mysql.mk
index cf5840131744..2a5edc80bb3c 100644
--- a/Mk/Uses/mysql.mk
+++ b/Mk/Uses/mysql.mk
@@ -5,8 +5,8 @@
#
# version If no version is given (by the maintainer via the port), try to
# find the currently installed version. Fall back to default if
-# necessary (MySQL-8.0 = 80, look at bsd.default-versions.mk for
-# possible values).
+# necessary (MariaDB-10.11 = 10.11m, look at bsd.default-versions.mk
+# for possible values).
# client Depends on the libmysqlclient library (default)
# server Depend on the server at run/build time. If none of these is
# set, depends on the client.
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 8b33dd90eda3..3b2e330c99ac 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -65,6 +65,7 @@ X11_CMAKE_BOOL= GLFW_BUILD_X11
.if ${PORT_OPTIONS:MEXAMPLES} && ${PORT_OPTIONS:MPREEDIT}
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
+TESTS_FILES= input_text
.endif
do-install-DOCS-on:
@@ -83,8 +84,9 @@ do-install-EXAMPLES-on:
${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/tests && ${INSTALL_PROGRAM} \
allocator clipboard cursor empty events gamma glfwinfo icon \
- iconify input_text inputlag joysticks monitors msaa reopen \
+ iconify inputlag joysticks monitors msaa reopen \
tearing threads timeout title triangle-vulkan window \
+ ${TESTS_FILES} \
${STAGEDIR}${EXAMPLESDIR}/tests
.include <bsd.port.mk>