aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-04-21 01:51:52 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-05-04 06:02:42 +0000
commita9ce8e7249a687eac971a3597cb184d520b81481 (patch)
tree9541e5697e00ddbb0e16e21dde834918a5e55149
parent09fa1cdbc4cf4b8d60b210241774d2dc9c6e9daa (diff)
downloadports-a9ce8e7249a687eac971a3597cb184d520b81481.tar.gz
ports-a9ce8e7249a687eac971a3597cb184d520b81481.zip
security/pinentry-qt6: Fix configure on 13.2
Qt 6.x requires C++17 and the C++ standard is not set for the configure script nor for the build. The base compiler on FreeBSD 13.2 defaults to C++11, causing the configure script to fail as would the build if it made it past the configure stage. Reported by: pkg-fallout (cherry picked from commit cc6cd777dae7001e3e3a8c5492a1cbbb7af5d346)
-rw-r--r--security/pinentry/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 87217f55c00c..1c36db0fdd9a 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -125,6 +125,7 @@ CONFIGURE_ARGS+=--disable-pinentry-qt5
.if ${PINENTRY_GUI} == "qt6"
USES+= compiler:c++17-lang kde:6 qt:6
+USE_CXXSTD= c++17
USE_KDE= guiaddons windowsystem
USE_QT= base
PLIST_FILES= bin/pinentry-qt \