aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2016-09-06 16:49:01 +0000
committerRenato Botelho <garga@FreeBSD.org>2016-09-06 16:49:01 +0000
commit2db0d6c4d370656bbefece99b302ebcac52da1a1 (patch)
tree96465c7359c0a4a8a6111773c828e08e0952ebd9
parent5b5010524022169f25da7cd24902a7dbe4ec858b (diff)
downloadports-2db0d6c4d370656bbefece99b302ebcac52da1a1.tar.gz
ports-2db0d6c4d370656bbefece99b302ebcac52da1a1.zip
MFH: r421378
Fix some edge cases in xinetd file descriptor handling This change fixes the case where the listening file descriptor is in 0~2 range (easily reprodutible with a single UDP service) PR: 211038 Obtained from: pfSense Sponsored by: Rubicon Communications (Netgate) Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2016Q3/; revision=421441
-rw-r--r--security/xinetd/Makefile2
-rw-r--r--security/xinetd/files/patch-xinetd_child.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 06ffe8f14b82..863b3f926db9 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xinetd
PORTVERSION= 2.3.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= GENTOO
diff --git a/security/xinetd/files/patch-xinetd_child.c b/security/xinetd/files/patch-xinetd_child.c
new file mode 100644
index 000000000000..6ddbf9125988
--- /dev/null
+++ b/security/xinetd/files/patch-xinetd_child.c
@@ -0,0 +1,24 @@
+--- xinetd/child.c.orig 2016-07-13 19:00:31 UTC
++++ xinetd/child.c
+@@ -168,7 +168,8 @@ void exec_server( const struct server *s
+ }
+ #endif
+
+- (void) Sclose( descriptor ) ;
++ if ( descriptor > MAX_PASS_FD )
++ (void) Sclose( descriptor ) ;
+
+ #ifndef solaris
+ #if !defined(HAVE_SETSID)
+@@ -321,11 +322,6 @@ void child_process( struct server *serp
+ signals_pending[0] = -1;
+ signals_pending[1] = -1;
+
+- Sclose(0);
+- Sclose(1);
+- Sclose(2);
+-
+-
+ #ifdef DEBUG_SERVER
+ if ( debug.on )
+ {