aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-29 02:35:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-29 02:35:54 +0000
commit3d1ce6403bb1ce37cece085faaead97507161ebd (patch)
tree6721a703a7c4a9ed72e6cf263535100354616ad1
parenteff4f9e0babd5976e6b03d0cb859d91c5d8677f3 (diff)
downloadports-3d1ce6403bb1ce37cece085faaead97507161ebd.tar.gz
ports-3d1ce6403bb1ce37cece085faaead97507161ebd.zip
MFH: r471073
emulators/ppsspp: unbreak on armv6/armv7 SDL/SDLGLGraphicsContext.cpp:88:2: error: use of undeclared identifier 'EGL_Init' EGL_Init(); ^ SDL/SDLGLGraphicsContext.cpp:122:18: error: use of undeclared identifier 'g_eglDisplay' eglSwapBuffers(g_eglDisplay, g_eglSurface); ^ SDL/SDLGLGraphicsContext.cpp:122:32: error: use of undeclared identifier 'g_eglSurface' eglSwapBuffers(g_eglDisplay, g_eglSurface); ^ SDL/SDLGLGraphicsContext.cpp:139:2: error: use of undeclared identifier 'EGL_Close' EGL_Close(); ^ Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q2/; revision=471074
-rw-r--r--emulators/ppsspp/Makefile1
-rw-r--r--emulators/ppsspp/files/patch-no-egl18
2 files changed, 18 insertions, 1 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 4d82fef3a2cc..24640bccdc20 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -36,7 +36,6 @@ EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
USE_GL= gl glew glu
USE_SDL= sdl2 # joystick
CMAKE_ON= USE_SYSTEM_FFMPEG
-CMAKE_OFF= USING_EGL
SUB_FILES= pkg-message
PORTDATA= assets ${PORTNAME}
diff --git a/emulators/ppsspp/files/patch-no-egl b/emulators/ppsspp/files/patch-no-egl
new file mode 100644
index 000000000000..962d800fc960
--- /dev/null
+++ b/emulators/ppsspp/files/patch-no-egl
@@ -0,0 +1,18 @@
+EGL hangs on X11 and doesn't build without GLESv2.
+https://github.com/hrydgard/ppsspp/issues/10626
+
+--- CMakeLists.txt.orig 2017-12-05 13:51:51 UTC
++++ CMakeLists.txt
+@@ -56,12 +56,6 @@ include(ccache)
+ # Remove soon?
+ set(USE_FFMPEG ON)
+
+-if(NOT ANDROID AND NOT IOS)
+- if(ARM OR SIMULATOR)
+- set(USING_EGL ON)
+- endif()
+-endif()
+-
+ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ set(LINUX ON)
+ add_definitions(-D__STDC_CONSTANT_MACROS)