aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1996-10-31 19:53:40 +0000
committerMark Murray <markm@FreeBSD.org>1996-10-31 19:53:40 +0000
commitcfa6d6025cf961f5103e5ff59e69393cf1038243 (patch)
tree8033c31945d4faac1a69f5bb750f1f81fe7b5101
parente7643e3110196b39d90ac92ef725fb6ee4b04bdb (diff)
downloadports-cfa6d6025cf961f5103e5ff59e69393cf1038243.tar.gz
ports-cfa6d6025cf961f5103e5ff59e69393cf1038243.zip
DejaGNU is an automated testing tool. It uses expect to run your tests.
Notes
Notes: svn path=/head/; revision=4223
-rw-r--r--misc/dejagnu/Makefile29
-rw-r--r--misc/dejagnu/distinfo1
-rw-r--r--misc/dejagnu/pkg-comment1
-rw-r--r--misc/dejagnu/pkg-descr22
-rw-r--r--misc/dejagnu/pkg-plist16
5 files changed, 69 insertions, 0 deletions
diff --git a/misc/dejagnu/Makefile b/misc/dejagnu/Makefile
new file mode 100644
index 000000000000..710a71e87efe
--- /dev/null
+++ b/misc/dejagnu/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dejagnu
+# Version required: 1.3
+# Date created: 12 October 1996
+# Whom: markm
+#
+# $Id$
+#
+
+DISTNAME= dejagnu-1.3
+PKGNAME= dejagnu-1.3
+CATEGORIES+= devel
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/dejagnu
+
+MAINTAINER= markm@FreeBSD.ORG
+
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= i386-freebsd --prefix=${PREFIX}
+STRIP=
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/runtest.1
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/dejagnu/distinfo b/misc/dejagnu/distinfo
new file mode 100644
index 000000000000..18d78c8d18ab
--- /dev/null
+++ b/misc/dejagnu/distinfo
@@ -0,0 +1 @@
+MD5 (dejagnu-1.3.tar.gz) = a43d6ef02db12f4fa4fe2daec2ed4cc1
diff --git a/misc/dejagnu/pkg-comment b/misc/dejagnu/pkg-comment
new file mode 100644
index 000000000000..79ad483871e1
--- /dev/null
+++ b/misc/dejagnu/pkg-comment
@@ -0,0 +1 @@
+Automated program/system tester
diff --git a/misc/dejagnu/pkg-descr b/misc/dejagnu/pkg-descr
new file mode 100644
index 000000000000..3da5ac89dc73
--- /dev/null
+++ b/misc/dejagnu/pkg-descr
@@ -0,0 +1,22 @@
+ DejaGnu is a framework for testing other programs. Its purpose is to
+provide a single front end for all tests. Beyond this, DejaGnu offers
+several advantages for testing:
+
+ - The flexibility and consistency of the DejaGnu framework
+ make it easy to write tests for any program.
+
+ - DejaGnu provides a layer of abstraction which makes all
+ tests (if correctly written) portable to any host or target
+ where a program must be tested. For instance, a test for
+ GDB can run (from any Unix based host) on any target
+ architecture supported by DejaGnu. Currently DejaGnu runs
+ tests on several single board computers, whose operating
+ software ranges from just a boot monitor to a full-fledged,
+ Unix-like realtime OS.
+
+ - DejaGnu is written in expect, which in turn uses Tcl
+ (Tool command language). The framework comprises two parts:
+ the testing framework and the testsuites themselves. Tests
+ are usually written in expect using Tcl.
+
+ Bugs can be reported to bug-dejagnu@prep.ai.mit.edu.
diff --git a/misc/dejagnu/pkg-plist b/misc/dejagnu/pkg-plist
new file mode 100644
index 000000000000..0fdc806bbc9b
--- /dev/null
+++ b/misc/dejagnu/pkg-plist
@@ -0,0 +1,16 @@
+bin/runtest
+lib/dejagnu/runtest.exp
+lib/dejagnu/config.guess
+lib/dejagnu/bug.exp
+lib/dejagnu/debugger.exp
+lib/dejagnu/dg.exp
+lib/dejagnu/framework.exp
+lib/dejagnu/libgloss.exp
+lib/dejagnu/remote.exp
+lib/dejagnu/target.exp
+lib/dejagnu/udi.exp
+lib/dejagnu/util-defs.exp
+lib/dejagnu/utils.exp
+lib/dejagnu/vrtx.exp
+lib/dejagnu/vxworks.exp
+man/man1/runtest.1.gz