aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2007-12-06 10:01:02 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2007-12-06 10:01:02 +0000
commit259debd67bbc32f7e927be2f2d912bbdcd18bfa1 (patch)
tree6abb4386500d0b6fe683f83da3acaaf1d496f1b7
parent118c6f4e0792849977169c74789960765771d165 (diff)
downloadports-259debd67bbc32f7e927be2f2d912bbdcd18bfa1.tar.gz
ports-259debd67bbc32f7e927be2f2d912bbdcd18bfa1.zip
- Added patch to remove -pie for radiusd. [1]
- Fixed a build failure on RELENG_7 AMD64. - Chase heimdal shared version library bump. [2] - Reworked RC script. [3] - Mark as unbroken on AMD64. - Bump PORTREVISION. PR: ports/118425, ports/117262 [3] Reported by: Sean McNeil <sean@mcneil.com> [1], Gioto Alves Lourenco <gioto@pop-ro.rnp.br> [2] Submitted by: Craig Leres <leres@ee.lbl.gov> [3], David Wood <david@wood2.org.uk> (maintainer) Approved by: portmgr (marcus), stas (mentor, implicit)
Notes
Notes: svn path=/head/; revision=202918
-rw-r--r--net/freeradius/Makefile18
-rw-r--r--net/freeradius/files/patch-radiusd-no-pie11
-rw-r--r--net/freeradius/files/radiusd.sh.in12
-rw-r--r--net/freeradius2/Makefile18
-rw-r--r--net/freeradius2/files/patch-radiusd-no-pie11
-rw-r--r--net/freeradius2/files/radiusd.sh.in12
6 files changed, 52 insertions, 30 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 93d83d62caf3..39e493e87754 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= freeradius
-PORTVERSION?= 1.1.7
-PORTREVISION?= 1
+PORTVERSION= 1.1.7
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/ \
@@ -16,15 +16,15 @@ MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/
MASTER_SITE_SUBDIR= . old
-MAINTAINER?= david@wood2.org.uk
-COMMENT?= A free RADIUS server implementation
+MAINTAINER= david@wood2.org.uk
+COMMENT= A free RADIUS server implementation
USE_BZIP2= yes
WANT_PERL= yes
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
-LOGDIR?= /var/log
+LOGDIR= /var/log
# If FREERADIUS_SLAVE_MYSQL is defined, we want to build the
# freeradius-mysql slave port
@@ -61,12 +61,6 @@ OPTIONS+= PGSQL "With PostgreSQL database support" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
# Default requirements for rc script
_REQUIRE= NETWORKING SERVERS
@@ -110,7 +104,7 @@ WITH_KERBEROS= yes
.ifdef(WITH_KERBEROS)
.ifdef(WITH_HEIMDAL)
-LIB_DEPENDS+= krb5.21:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= krb5.23:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--enable-heimdal-krb5
.else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
diff --git a/net/freeradius/files/patch-radiusd-no-pie b/net/freeradius/files/patch-radiusd-no-pie
new file mode 100644
index 000000000000..bf0772399683
--- /dev/null
+++ b/net/freeradius/files/patch-radiusd-no-pie
@@ -0,0 +1,11 @@
+--- src/main/Makefile.in Wed Feb 14 15:44:23 2007
++++ src/main/Makefile.in Mon Dec 3 14:26:53 2007
+@@ -61,7 +61,7 @@
+
+ radiusd: $(SERVER_OBJS) $(MODULE_OBJS) ../lib/libradius.la
+ $(LIBTOOL) --mode=link $(CC) -export-dynamic -dlopen self \
+- $(LDFLAGS) -pie $(LINK_MODE) -o $@ $(SERVER_OBJS) \
++ $(LDFLAGS) $(LINK_MODE) -o $@ $(SERVER_OBJS) \
+ $(MODULE_LIBS) $(LIBS) $(SNMP_LIBS) $(PTHREADLIB) \
+ $(LIBLTDL) $(OPENSSL_LIBS)
+
diff --git a/net/freeradius/files/radiusd.sh.in b/net/freeradius/files/radiusd.sh.in
index af481ff162eb..a29083d64fab 100644
--- a/net/freeradius/files/radiusd.sh.in
+++ b/net/freeradius/files/radiusd.sh.in
@@ -14,13 +14,19 @@
name=radiusd
rcvar=`set_rcvar`
+load_rc_config $name
command=%%PREFIX%%/sbin/radiusd
-radiusd_config=${radiusd_config:-"%%PREFIX%%/etc/raddb/radiusd.conf"}
-required_files=${radiusd_config}
pidfile=/var/run/radiusd/radiusd.pid
+# The radiusd_config parameter is now obsolete. Instead, derive the
+# configuration directory name from radiusd_flags if possible, otherwise
+# default to %%PREFIX%%/etc/raddb
+required_dirs=`echo ${radiusd_flags} | sed -Ee 's:.*\-[^[:space:]d]*d[[:space:]]*([^[:space:]]+).*:\1:'`
+required_dirs=${required_dirs:-"%%PREFIX%%/etc/raddb"}
+
+required_files="${required_dirs}/radiusd.conf"
+
radiusd_enable=${radiusd_enable-"NO"}
-load_rc_config $name
run_rc_command "$1"
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 93d83d62caf3..39e493e87754 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= freeradius
-PORTVERSION?= 1.1.7
-PORTREVISION?= 1
+PORTVERSION= 1.1.7
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/ \
@@ -16,15 +16,15 @@ MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/
MASTER_SITE_SUBDIR= . old
-MAINTAINER?= david@wood2.org.uk
-COMMENT?= A free RADIUS server implementation
+MAINTAINER= david@wood2.org.uk
+COMMENT= A free RADIUS server implementation
USE_BZIP2= yes
WANT_PERL= yes
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
-LOGDIR?= /var/log
+LOGDIR= /var/log
# If FREERADIUS_SLAVE_MYSQL is defined, we want to build the
# freeradius-mysql slave port
@@ -61,12 +61,6 @@ OPTIONS+= PGSQL "With PostgreSQL database support" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-.if ${ARCH} == "amd64"
-BROKEN= Does not compile with GCC 4.2
-.endif
-.endif
-
# Default requirements for rc script
_REQUIRE= NETWORKING SERVERS
@@ -110,7 +104,7 @@ WITH_KERBEROS= yes
.ifdef(WITH_KERBEROS)
.ifdef(WITH_HEIMDAL)
-LIB_DEPENDS+= krb5.21:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= krb5.23:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--enable-heimdal-krb5
.else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
diff --git a/net/freeradius2/files/patch-radiusd-no-pie b/net/freeradius2/files/patch-radiusd-no-pie
new file mode 100644
index 000000000000..bf0772399683
--- /dev/null
+++ b/net/freeradius2/files/patch-radiusd-no-pie
@@ -0,0 +1,11 @@
+--- src/main/Makefile.in Wed Feb 14 15:44:23 2007
++++ src/main/Makefile.in Mon Dec 3 14:26:53 2007
+@@ -61,7 +61,7 @@
+
+ radiusd: $(SERVER_OBJS) $(MODULE_OBJS) ../lib/libradius.la
+ $(LIBTOOL) --mode=link $(CC) -export-dynamic -dlopen self \
+- $(LDFLAGS) -pie $(LINK_MODE) -o $@ $(SERVER_OBJS) \
++ $(LDFLAGS) $(LINK_MODE) -o $@ $(SERVER_OBJS) \
+ $(MODULE_LIBS) $(LIBS) $(SNMP_LIBS) $(PTHREADLIB) \
+ $(LIBLTDL) $(OPENSSL_LIBS)
+
diff --git a/net/freeradius2/files/radiusd.sh.in b/net/freeradius2/files/radiusd.sh.in
index af481ff162eb..a29083d64fab 100644
--- a/net/freeradius2/files/radiusd.sh.in
+++ b/net/freeradius2/files/radiusd.sh.in
@@ -14,13 +14,19 @@
name=radiusd
rcvar=`set_rcvar`
+load_rc_config $name
command=%%PREFIX%%/sbin/radiusd
-radiusd_config=${radiusd_config:-"%%PREFIX%%/etc/raddb/radiusd.conf"}
-required_files=${radiusd_config}
pidfile=/var/run/radiusd/radiusd.pid
+# The radiusd_config parameter is now obsolete. Instead, derive the
+# configuration directory name from radiusd_flags if possible, otherwise
+# default to %%PREFIX%%/etc/raddb
+required_dirs=`echo ${radiusd_flags} | sed -Ee 's:.*\-[^[:space:]d]*d[[:space:]]*([^[:space:]]+).*:\1:'`
+required_dirs=${required_dirs:-"%%PREFIX%%/etc/raddb"}
+
+required_files="${required_dirs}/radiusd.conf"
+
radiusd_enable=${radiusd_enable-"NO"}
-load_rc_config $name
run_rc_command "$1"