aboutsummaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-15 14:17:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-18 10:32:16 +0000
commitb731fff69c0ffd79f80f5d1d575e016337f3b920 (patch)
tree58bb38286f4f3858c7e13ede0dd20c525cf4fc54 /CHANGES
parent1cfe12ed25e54bf4df6639601e7c5d58f023aa4c (diff)
downloadports-b731fff69c0ffd79f80f5d1d575e016337f3b920.tar.gz
ports-b731fff69c0ffd79f80f5d1d575e016337f3b920.zip
Mk/Uses: Add pytest.mk
Add USES=pytest, a standardized pytest entry point. This knob adds dependency on pytest and defines do-test target which calls it "the right way" (respecting TEST_ENV, with proper verbosity, additional info on skipped tests, and resetting addopts which may be set by upstream and introduce unwanted options). This allows to remove duplicate (and in many cases not completely correct) do-test targets from a lot of pytest consumer ports. Additionally, it adds PYTEST_IGNORED_TESTS (to list tests which fail and are expected to fail) and PYTEST_BROKEN_TESTS (to list tests which fail and needs to be fixed). Both knobs lead to listed tests being skipped, which is believed to be better than always failing `test` target, allowing to monitor status of other tests and better document known failures. Possible room for improvement: - Support for pytest plugins (add dependencies and disallow pytest from using unlisted plugins which often cause breakages) - Treat PYTEST_BROKEN_TESTS as xfail to catch the cases when tests are fixed. Both items seem to require support on pytest side though. Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D34693
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES13
1 files changed, 13 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index bb1fdcf4d997..e96e1b0d4a0d 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,19 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20220415:
+AUTHOR: amdmi3@FreeBSD.org
+
+ A new USES has been added to handle testing with pytest.
+
+ USES= pytest
+
+ Introduces dependency on pytest and adds do-test target which calls
+ pytest with the right environment and arguments.
+
+ Additionally, PYTEST_{IGNORED,BROKEN}_TESTS knobs are provided for
+ skipping failing tests in a convenient and documented way.
+
20220218:
AUTHOR: jrm@FreeBSD.org