aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-03-09 19:25:49 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-03-09 19:38:13 +0000
commit4caa2e2b27f1f5728591ccd9bba370791b7c8f28 (patch)
tree2cee32bce7533ec8bb57b1c484b7df037a70ea25 /Mk
parent09079730e9ca1d59129935a6046cbb7ee5e4a93d (diff)
downloadports-4caa2e2b27f1f5728591ccd9bba370791b7c8f28.tar.gz
ports-4caa2e2b27f1f5728591ccd9bba370791b7c8f28.zip
Mk/Uses: Drop the "/package/" part of URI when calling cabal2tuple.
Some repositories unlike Hackage append "/package/" when accessing a package. This confuses cabal2tuple, so chop it.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cabal.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/cabal.mk b/Mk/Uses/cabal.mk
index 23d0b0fa6ebb..0dda929e7e57 100644
--- a/Mk/Uses/cabal.mk
+++ b/Mk/Uses/cabal.mk
@@ -173,7 +173,7 @@ EXTRACT_ONLY+= ${_CABAL_EXTRACT_ONLY}
. if defined(CABAL_REPOSITORIES) && !empty(CABAL_REPOSITORIES)
. for r in ${CABAL_REPOSITORIES}
-CABAL2TUPLE_ARGS+= --group=${r} --master-site=${MASTER_SITES:M*\:${r}:[1]:S/:${r}//}
+CABAL2TUPLE_ARGS+= --group=${r} --master-site=${MASTER_SITES:M*\:${r}:[1]:S/:${r}//:S|/package/||}
. endfor
. endif