aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2023-03-09 02:17:52 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2023-03-09 02:17:52 +0000
commitd4f3d79c367cdbcac8927e2a730a98982a10e50e (patch)
treeb786dde3d16f478bf0ff3dfb6da1cce5aa3af897 /Mk
parent89db86003595725638977f09c2435f5f60ec0835 (diff)
downloadports-d4f3d79c367cdbcac8927e2a730a98982a10e50e.tar.gz
ports-d4f3d79c367cdbcac8927e2a730a98982a10e50e.zip
math/octave: Update to 8.1.0.
Bump portrevision of all dependent ports. Mark broken math/octave-forge-database, math/octave-forge-mechanics, math/octave-forge-mpi math/octave-forge-nlwing2, math/octave-forge-parallel, math/octave-forge-specfun Set to default off these ports in math/octave-forge. Clean up indentation in Mk/Uses/octave.mk.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/octave.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/Mk/Uses/octave.mk b/Mk/Uses/octave.mk
index e5c6be62df25..35782a88da84 100644
--- a/Mk/Uses/octave.mk
+++ b/Mk/Uses/octave.mk
@@ -22,25 +22,25 @@ IGNORE= Incorrect 'USES+= octave:${octave_ARGS}' usage: argument [${arg}] is not
. endif
. endfor
-OCTAVE_VERSION= 7.3.0
+OCTAVE_VERSION= 8.1.0
-. if empty(octave_ARGS:Menv)
+. if empty(octave_ARGS:Menv)
BUILD_DEPENDS+= octave:math/octave
RUN_DEPENDS+= octave:math/octave \
${LOCALBASE}/libexec/octave/load-octave-pkg:math/octave-forge-base
LIB_DEPENDS+= libpcre.so:devel/pcre
-. if ! ${USES:Mcompiler}
+. if ! ${USES:Mcompiler}
_USES_POST+= compiler:c++14-lang
-. endif
+. endif
-. if ! ${USES:Mfortran}
+. if ! ${USES:Mfortran}
_USES_POST+= fortran
-. endif
+. endif
-. if ! ${USES:Mgmake}
+. if ! ${USES:Mgmake}
_USES_POST+= gmake
-. endif
+. endif
CXXFLAGS+= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION}
CFLAGS+= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION}
@@ -59,17 +59,17 @@ MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD_CXX="${CXX}" DL_LD="${CXX}" MKOCTFILE="${L
LOAD_OCTAVE_PKG_CMD= ${LOCALBASE}/libexec/octave/load-octave-pkg
-. if !target(pre-install)
+. if !target(pre-install)
pre-install: octave-pre-install
-. endif # !target(pre-install)
+. endif # !target(pre-install)
-. if !target(do-install)
+. if !target(do-install)
do-install: octave-do-install
-. endif # !target(do-install)
+. endif # !target(do-install)
-. if !target(post-install)
+. if !target(post-install)
post-install: octave-post-install
-. endif # !target(post-install)
+. endif # !target(post-install)
octave-pre-install:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
@@ -85,6 +85,6 @@ octave-post-install:
@${ECHO_CMD} "share/octave/tarballs/${OCTAVE_PKGNAME}.tar.gz" >> ${TMPPLIST}
@${ECHO_CMD} "@postunexec if [ -x ${LOAD_OCTAVE_PKG_CMD} ]; then ${LOAD_OCTAVE_PKG_CMD}; fi" >> ${TMPPLIST}
@${ECHO_CMD} "@postexec if [ -x ${LOAD_OCTAVE_PKG_CMD} ]; then ${LOAD_OCTAVE_PKG_CMD}; fi" >> ${TMPPLIST}
-. endif # empty(octave_ARGS:Menv)
+. endif # empty(octave_ARGS:Menv)
.endif # !defined(_INCLUDE_USES_OCTAVE_MK)