aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-30 21:58:53 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-30 21:58:53 +0000
commit62905168fc68955024ecf3a2ff96f1cf489cc98f (patch)
tree32129a92c18529123c48ec0f34b4f56c0d8cb9a4 /Mk
parente8db97680df0c7b32a564488c223dbd251d9eab4 (diff)
downloadports-62905168fc68955024ecf3a2ff96f1cf489cc98f.tar.gz
ports-62905168fc68955024ecf3a2ff96f1cf489cc98f.zip
Mk: unregister removed GhostScript 8 ports
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ghostscript.mk16
-rw-r--r--Mk/bsd.default-versions.mk2
2 files changed, 7 insertions, 11 deletions
diff --git a/Mk/Uses/ghostscript.mk b/Mk/Uses/ghostscript.mk
index 9fffd0b34a9b..af38582e8384 100644
--- a/Mk/Uses/ghostscript.mk
+++ b/Mk/Uses/ghostscript.mk
@@ -4,12 +4,12 @@
# Usage: USES=ghostscript or USES=ghostscript:args
# Valid ARGS: <version>, build, run, test, x11
#
-# version The chooseable versions are 8, 9 and agpl. If no version is
+# version The chooseable versions are 9 and agpl. If no version is
# specified version agpl is selected.
#
-# USES=ghostscript:8 # Use Ghostscript 8
+# USES=ghostscript:9 # Use Ghostscript 9
# USES=ghostscript:run # Use the set default Ghostscript as a run dependency
-# USES=ghostscript:8,build # Use ghostscript 8 as a build dependency.
+# USES=ghostscript:9,build # Use ghostscript 9 as a build dependency.
#
# x11 Indicate that X11 support is required.
# build Indicates that Ghostscript is needed at build time and adds
@@ -30,15 +30,15 @@ _INCLUDE_USES_GHOSTSCRIPT_MK= yes
# allowed versions
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_GS_VERSION= 8 9 agpl
+_GS_VERSION= 9 agpl
_GS_ARGS= ${ghostscript_ARGS}
-. if ${_GS_ARGS:N[89]:Nagpl:Nx11:Nbuild:Nrun:Ntest}
+. if ${_GS_ARGS:N[9]:Nagpl:Nx11:Nbuild:Nrun:Ntest}
IGNORE?= Unknown ghostscript argument ${_GS_ARGS}
. endif
-. if ${GHOSTSCRIPT_DEFAULT:N[789]:Nagpl}
+. if ${GHOSTSCRIPT_DEFAULT:N[9]:Nagpl}
IGNORE?= Invalid GHOSTSCRIPT_DEFAULT value: ${GHOSTSCRIPT_DEFAULT}, please select one of ${_GS_VERSION}
. endif
@@ -71,8 +71,6 @@ _V=${V}
_GS_SELECTED?= 9
. elif ${_V:Magpl}
_GS_SELECTED?= 9-agpl
-. elif ${_V:M8}
-_GS_SELECTED?= 8
. endif
. endfor
@@ -81,8 +79,6 @@ _GS_SELECTED?= 8
_GS_VERSION_MINOR= 9.16_2
. elif !empty(_GS_SELECTED:M9)
_GS_VERSION_MINOR= 9.06_11
-. elif !empty(_GS_SELECTED:M8)
-_GS_VERSION_MINOR= 8.71_19
. endif
# dependencies
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index b82345dc7a27..e3fac4c45918 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -53,7 +53,7 @@ GCC_DEFAULT?= 8
. else
GCC_DEFAULT?= 12
. endif
-# Possible values: 8, 9, agpl
+# Possible values: 9, agpl
GHOSTSCRIPT_DEFAULT?= agpl
# Possible values: mesa-libs, mesa-devel
GL_DEFAULT?= mesa-libs