aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:30:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 00:46:32 +0000
commit204d12db0162d8e28c3ff536da2be7b0dc35850e (patch)
tree565b565ee9a20429a7a59566b469c7de965a9689 /Mk
parent1b5e6e9144bb3f29d96f861ebf0ce60be4813ba3 (diff)
downloadports-204d12db0162d8e28c3ff536da2be7b0dc35850e.tar.gz
ports-204d12db0162d8e28c3ff536da2be7b0dc35850e.zip
Mk/bsd.default-versions.mk: Remove PYTHON3_DEFAULT and use PYTHON_DEFAULT for Python 3.x
- Remove unnecessary PYTHON3_DEFAULT - Use PYTHON_DEFAULT for Python 3.x and remove 2.7 from PYTHON_DEFAULT - Use PYTHON2_DEFAULT for Python 2.7 Regarding DEFAULT_VERSIONS, both python and python3 point to the same value which makes python3 a duplicate. And we do not really support python=2.7. Therefore, use python for Python 3.x and python2 for legacy Python 2.7.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.default-versions.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index 5e7af95493f5..053ff5af9cea 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -20,7 +20,7 @@ LOCALBASE?= /usr/local
. for lang in APACHE BDB COROSYNC EBUR128 EMACS FIREBIRD FORTRAN FPC GCC \
GHOSTSCRIPT GL GO GUILE IMAGEMAGICK JAVA LAZARUS LIBRSVG2 LINUX LLVM \
LUA LUAJIT MONO MYSQL NINJA NODEJS OPENLDAP PERL5 PGSQL PHP \
- PYCRYPTOGRAPHY PYTHON PYTHON2 PYTHON3 RUBY RUST SAMBA SSL TCLTK VARNISH
+ PYCRYPTOGRAPHY PYTHON PYTHON2 RUBY RUST SAMBA SSL TCLTK VARNISH
. if defined(${lang}_DEFAULT)
ERROR+= "The variable ${lang}_DEFAULT is set and it should only be defined through DEFAULT_VERSIONS+=${lang:tl}=${${lang}_DEFAULT} in /etc/make.conf"
. endif
@@ -134,12 +134,10 @@ PYCRYPTOGRAPHY_DEFAULT?= rust
. else
PYCRYPTOGRAPHY_DEFAULT?= legacy
. endif
-# Possible values: 2.7, 3.8, 3.9, 3.10, 3.11
+# Possible values: 3.8, 3.9, 3.10, 3.11
PYTHON_DEFAULT?= 3.9
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
-# Possible values: 3.8, 3.9, 3.10, 3.11
-PYTHON3_DEFAULT?= 3.9
# Possible values: 3.0, 3.1, 3.2, 3.3
RUBY_DEFAULT?= 3.1
# Possible values: rust, rust-nightly