aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-12-23 23:04:40 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-12-29 11:52:47 +0000
commit3aeb8b79ba651293817ac01ea6f8e9119766017e (patch)
treefb21105d000df32ae1ceb2ee956dc2c4add5447a /Mk
parent4eac9929c2b7bbfabd0b8a2ae235b73b30230066 (diff)
downloadports-3aeb8b79ba651293817ac01ea6f8e9119766017e.tar.gz
ports-3aeb8b79ba651293817ac01ea6f8e9119766017e.zip
Qt5: Update Qt 5 to 5.15.7
* rebase the KDE patched Qt5 ontop of the 5.15.7 branch * update qt5-script to 5.15.11 Exp-run by: antoine PR: 268533
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt-dist.mk28
-rw-r--r--Mk/Uses/qt.mk2
2 files changed, 16 insertions, 14 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index c22a001c8c83..54cd6032d826 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -98,42 +98,43 @@ DIST_SUBDIR= KDE/Qt/${_QT_VERSION}
. if ${_QT_VER:M5}
# KDE maintains a repository with a patched Qt5 distribution.
-_KDE_3d= 15
-_KDE_base= 165
-_KDE_charts= 1
+_KDE_3d= 6
+_KDE_base= 177
+_KDE_charts= 0
_KDE_connectivity= 5
_KDE_datavis3d= 0
-_KDE_declarative= 19
+_KDE_declarative= 25
_KDE_gamepad= 0
_KDE_graphicaleffects= 0
-_KDE_imageformats= 3
+_KDE_imageformats= 6
_KDE_location= 3
_KDE_multimedia= 1
_KDE_networkauth= 0
_KDE_quick3d= 1
+_KDE_quickcontrols2= 7
_KDE_quickcontrols= 0
-_KDE_quickcontrols2= 6
_KDE_quicktimeline= 0
_KDE_remoteobjects= 0
_KDE_script= 0
-_KDE_script_ORIGIN_TAG= v5.15.10-lts
-_KDE_script_VERSION= 5.15.10
+_KDE_script_ORIGIN_TAG= v5.15.11-lts
+_KDE_script_VERSION= 5.15.11
_KDE_scxml= 0
_KDE_sensors= 0
_KDE_serialbus= 0
_KDE_serialport= 0
_KDE_speech= 1
-_KDE_svg= 10
+_KDE_svg= 9
_KDE_tools= 1
-_KDE_translations= 2
-_KDE_virtualkeyboard= 3
-_KDE_wayland= 39
+_KDE_translations= 0
+_KDE_virtualkeyboard= 0
+_KDE_wayland= 58
_KDE_webchannel= 3
_KDE_webglplugin= 0
-_KDE_websockets= 3
+_KDE_websockets= 2
_KDE_webview= 0
_KDE_x11extras= 0
_KDE_xmlpatterns= 0
+
. if defined(_KDE_${_QT_DIST})
QT5_KDE_PATCH= p${_KDE_${_QT_DIST}}
_KDE_${_QT_DIST}_VERSION?= ${_QT_VERSION}
@@ -509,6 +510,7 @@ qt6-post-stage:
. endif
qt-create-kde-distfile:
+ ${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
${SH} ${PORTSDIR}/devel/${_QT_RELNAME}/files/create_kde-qt_release.sh \
${_QT_DIST} \
${DISTDIR}/${DIST_SUBDIR} \
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index f022d93cec05..3332fdb15061 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -22,7 +22,7 @@ _QT_MK_INCLUDED= qt.mk
# Qt versions currently supported by the framework.
_QT_SUPPORTED?= 5 6
-QT5_VERSION?= 5.15.5
+QT5_VERSION?= 5.15.7
QT6_VERSION?= 6.4.1
# We accept the Qt version to be passed by either or all of the three mk files.