aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:42:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 16:42:09 +0000
commitefd2fec0e7efe154baf8e889f25b0438ae30f1d7 (patch)
tree3b117dc8f8c7555a2ba80213ebdd942a5a72c6ba /archivers
parent73c935b13e84821eb11bc8a3b6d8bf1847dd92c9 (diff)
downloadports-efd2fec0e7efe154baf8e889f25b0438ae30f1d7.tar.gz
ports-efd2fec0e7efe154baf8e889f25b0438ae30f1d7.zip
archivers/dzip: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'archivers')
-rw-r--r--archivers/dzip/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/archivers/dzip/Makefile b/archivers/dzip/Makefile
index a5b584b37d2d..037bd9efb2e4 100644
--- a/archivers/dzip/Makefile
+++ b/archivers/dzip/Makefile
@@ -24,6 +24,12 @@ PORTDOCS= Readme
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-extract: .SILENT
${REINPLACE_CMD} -e 's/ifdef BIG_ENDIAN/if BYTE_ORDER == BIG_ENDIAN/' \
-e 's/ifndef BIG_ENDIAN/if BYTE_ORDER == LITTLE_ENDIAN/' \