aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-27 18:26:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-27 18:26:18 +0000
commit98a5bad457379d61fb50ac62ecc1f9a0e0d4b185 (patch)
tree420216569c694dca6c4e0d70204cc2b7efbd86ab /benchmarks
parente807fb8510bd63fba611e6200fec4f7ba1cd7a8c (diff)
downloadports-98a5bad457379d61fb50ac62ecc1f9a0e0d4b185.tar.gz
ports-98a5bad457379d61fb50ac62ecc1f9a0e0d4b185.zip
benchmarks/vkoverhead: mark BROKEN on armv7
../src/vkoverhead.c:859:18: error: incompatible pointer to integer conversion initializing 'VkPipeline' (aka 'unsigned long long') with an expression of type 'void *' [-Werror,-Wint-conversion] VkPipeline pipeline = he->data; ^ ~~~~~~~~ ../src/vkoverhead.c:3084:63: error: incompatible integer to pointer conversion passing 'VkPipeline' (aka 'unsigned long long') to parameter of type 'void *' [-Werror,-Wint-conversion] _mesa_hash_table_insert(&gpl_pipeline_table, key, pipeline_gpl_vert_final[i]); ^~~~~~~~~~~~~~~~~~~~~~~~~~ ../util/hash_table.h:92:71: note: passing argument to parameter 'data' here _mesa_hash_table_insert(struct hash_table *ht, const void *key, void *data); ^ Reported by: pkg-fallout
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/vkoverhead/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/benchmarks/vkoverhead/Makefile b/benchmarks/vkoverhead/Makefile
index f92618d0c93e..27ed30d7a4e8 100644
--- a/benchmarks/vkoverhead/Makefile
+++ b/benchmarks/vkoverhead/Makefile
@@ -14,6 +14,7 @@ WWW= https://github.com/zmike/vkoverhead
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_armv7= fails to build due -Werror=int-conversion
BROKEN_i386= fails to build due -Werror=int-conversion
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako@${PY_FLAVOR}