aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-07-25 18:58:10 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-07-25 18:58:10 +0000
commit813409127c0d8671332b389ce5bfc095caca46e7 (patch)
treeadedced4582856d962e88d74dead8af7dfe5f462 /benchmarks
parent7950ac6a6755d3a3def7c04feb5f49b02f7a053e (diff)
downloadports-813409127c0d8671332b389ce5bfc095caca46e7.tar.gz
ports-813409127c0d8671332b389ce5bfc095caca46e7.zip
benchmarks/phoronix-test-suite: use SHEBANG_GLOB instead of SHEBANG_FILES incomplete list (+)
Pet stage-qa by switch to SHEBANG_GLOB= *.sh This eliminate a bunch of 'Error: '/bin/bash' is an invalid shebang you need USES=shebangfix for...' Reported by: poudriere bulk -t Approved by: portmgr blanket Sponsored by: Serenity Cybersecurity, LLC
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/phoronix-test-suite/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/benchmarks/phoronix-test-suite/Makefile b/benchmarks/phoronix-test-suite/Makefile
index 63d07224ef1f..be1f0aaaf7fc 100644
--- a/benchmarks/phoronix-test-suite/Makefile
+++ b/benchmarks/phoronix-test-suite/Makefile
@@ -1,6 +1,7 @@
PORTNAME= phoronix-test-suite
DISTVERSIONPREFIX= v
DISTVERSION= 10.8.4
+PORTREVISION= 1
CATEGORIES= benchmarks
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -12,7 +13,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= sudo:security/sudo \
- bash:shells/bash
+ bash:shells/bash
USES= php:cli,build,flavors python shebangfix
USE_GITHUB= yes
@@ -23,18 +24,8 @@ PORTDATA= *
PORTDOCS= *
NO_ARCH= yes
-SHEBANG_FILES= ob-cache/test-profiles/pts/shadowofthetombraider-1.0.0/install.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.0/interim.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.0/pre.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.0/post.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.1/install.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.1/interim.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.1/pre.sh \
- ob-cache/test-profiles/pts/shadowofthetombraider-1.0.1/post.sh \
- ob-cache/test-profiles/pts/csgo-1.5.1/pre_linux.sh \
- ob-cache/test-profiles/pts/dota2-1.2.2/pre_linux.sh \
- ob-cache/test-profiles/pts/portal-1.1.1/pre_linux.sh \
- deploy/docker/ubuntu-pts-docker-build.sh
+
+SHEBANG_GLOB= *.sh
CONFLICTS_INSTALL= phoronix-test-suite-php[0-9][0-9] # bin/phoronix-test-suite