aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-04 22:45:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-04 22:48:00 +0000
commit77594feff67cf6792d805e079eb5567c21a125a7 (patch)
tree0adcddc96fc50f020b1bbb3fc1a00330f03575b3 /cad
parent8905cb6ecee3027cba5dd41996617f6c76bbf1c0 (diff)
downloadports-77594feff67cf6792d805e079eb5567c21a125a7.tar.gz
ports-77594feff67cf6792d805e079eb5567c21a125a7.zip
cad/scotch: Add missing include statements in include/scotch.h
Otherwise int64_t and FILE are not found. PR: 275527 Approved by: thierry@FreeBSD.org (maintainer)
Diffstat (limited to 'cad')
-rw-r--r--cad/scotch/Makefile2
-rw-r--r--cad/scotch/files/patch-src_libscotch_library.h16
2 files changed, 17 insertions, 1 deletions
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 9fb933476d7d..94b860411305 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -1,6 +1,6 @@
PORTNAME= scotch
DISTVERSION= 6.0.4-aster7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= cad science
MAINTAINER= thierry@FreeBSD.org
diff --git a/cad/scotch/files/patch-src_libscotch_library.h b/cad/scotch/files/patch-src_libscotch_library.h
new file mode 100644
index 000000000000..9af926eebfad
--- /dev/null
+++ b/cad/scotch/files/patch-src_libscotch_library.h
@@ -0,0 +1,16 @@
+- workaround for:
+- - https://gitlab.inria.fr/scotch/scotch/-/issues/35
+- - https://github.com/FreeFem/FreeFem-sources/issues/296
+
+--- src/libscotch/library.h.orig 2017-02-22 07:20:57 UTC
++++ src/libscotch/library.h
+@@ -61,6 +61,9 @@
+ #ifndef SCOTCH_H
+ #define SCOTCH_H
+
++#include <sys/types.h>
++#include <stdio.h>
++
+ /*
+ ** The type and structure definitions.
+ */